Bug 1257047 - Generating post install configuration file '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf' failed
Generating post install configuration file '/etc/ovirt-engine-setup.conf.d/20...
Status: CLOSED DUPLICATE of bug 1255638
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Alon Bar-Lev
Gonza
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 03:23 EDT by Pavel Stehlik
Modified: 2016-01-04 00:39 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-29 12:58:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Stehlik 2015-08-26 03:23:25 EDT
Description of problem:
I feel this is one issue thus putting in one BZ. If you feel otherwise - let me know I can split (or you can as well). I tried to create one BZ, but excuse me, once I get 3 different failures when reproducing by exactly same steps... 
 
I install it three times - every time the result is failed - however in each run it failed in different point. 
During installation when using non-Ascii as a Org. name for cert (eg: 'čína') 

--== CONGIGURATION PREVIEW ==--
...
         Engine installation                     : True
          PKI organization                        : �čína
          Configure local Engine database         : True
          Set application as default page         : True
...


1) log - ovirt-engine-setup-20150825130656-bnpzg5.log
...
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc4 in position 30: ordinal not in range(128)
2015-08-25 13:13:41 ERROR otopi.context context._executeMethod:164 Failed to execute stage 'Misc configuration': 'ascii' codec can't decode byte 0xc4 in position 30: ordinal not in range(128)



2) log - ovirt-engine-setup-20150826070658-qktoo8.log
It looks like previous issue, but it failed during cert generation - this point is even earlier than the issue from yesterday!
...
140090134959944:error:0D07A086:asn1 encoding routines:ASN1_mbstring_ncopy:invalid utf8string:a_mbstr.c:132:
Cannot enroll CA certificate
...
015-08-26 07:11:04 ERROR otopi.context context._executeMethod:164 Failed to execute stage 'Misc configuration': Command '/usr/share/ovirt-engine/bin/pki-create-ca.sh' failed to execute



3) log - /var/log/ovirt-engine/setup/ovirt-engine-setup-20150826071732-gvkwnq.log
It failed even before these previous runs.
...
X509Error: 140434694452992:error:0906D06C:PEM routines:PEM_read_bio:no start line:pem_lib.c:703:Expecting: CERTIFICATE

2015-08-26 07:18:50 ERROR otopi.context context._executeMethod:164 Failed to execute stage 'Environment customization': 140434694452992:error:0906D06C:PEM routines:PEM_read_bio:no start line:pem_lib.c:703:Expecting: CERTIFICATE
...



Version-Release number of selected component (if applicable):
rhevm-setup-base-3.6.0-0.12.master.el6.noarch


How reproducible:
100%

Steps to Reproduce:
1. use non ASCII char as Org. cert. name
2.
3.

Actual results:
Setup fail & rolled back.

Expected results:
Either limitation for ASCII or successful installation.

Additional info:
1st issue)
...
2015-08-25 13:13:41 DEBUG otopi.context context._executeMethod:141 Stage misc METHOD otopi.plugins.ovirt_engine_common.base.core.postinstall.Plugin._misc
2015-08-25 13:13:41 INFO otopi.plugins.ovirt_engine_common.base.core.postinstall postinstall._misc:57 Generating post install configuration file '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf'
2015-08-25 13:13:41 DEBUG otopi.context context._executeMethod:155 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 145, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-common/base/core/postinstall.py", line 86, in _misc
    otopicons.CoreEnv.MODIFIED_FILES
  File "/usr/lib/python2.6/site-packages/otopi/filetransaction.py", line 158, in __init__
    self._content = '\n'.join(content)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc4 in position 30: ordinal not in range(128)
2015-08-25 13:13:41 ERROR otopi.context context._executeMethod:164 Failed to execute stage 'Misc configuration': 'ascii' codec can't decode byte 0xc4 in position 30: ordinal not in range(128)
2015-08-25 13:13:41 DEBUG otopi.transaction transaction.abort:134 aborting 'Yum Transaction'
...



2nd issue)
...
Signature ok
140090134959944:error:0D07A086:asn1 encoding routines:ASN1_mbstring_ncopy:invalid utf8string:a_mbstr.c:132:
Cannot enroll CA certificate

2015-08-26 07:11:04 DEBUG otopi.context context._executeMethod:155 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 145, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine/pki/ca.py", line 652, in _misc
    oengcommcons.ConfigEnv.JAVA_HOME
  File "/usr/lib/python2.6/site-packages/otopi/plugin.py", line 945, in execute
    command=args[0],
RuntimeError: Command '/usr/share/ovirt-engine/bin/pki-create-ca.sh' failed to execute
2015-08-26 07:11:04 ERROR otopi.context context._executeMethod:164 Failed to execute stage 'Misc configuration': Command '/usr/share/ovirt-engine/bin/pki-create-ca.sh' failed to execute
...


3rd issue)
...
2015-08-26 07:18:50 DEBUG otopi.context context._executeMethod:141 Stage customization METHOD otopi.plugins.ovirt_engine_setup.ovirt_engine.pki.ca.Plugin._customization_upgrade
2015-08-26 07:18:50 DEBUG otopi.context context._executeMethod:155 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 145, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine/pki/ca.py", line 418, in _customization_upgrade
    oenginecons.FileLocations.OVIRT_ENGINE_PKI_ENGINE_CA_CERT
  File "/usr/lib64/python2.6/site-packages/M2Crypto/X509.py", line 611, in load_cert
    return load_cert_bio(bio)
  File "/usr/lib64/python2.6/site-packages/M2Crypto/X509.py", line 639, in load_cert_bio
    raise X509Error(Err.get_error())
X509Error: 140434694452992:error:0906D06C:PEM routines:PEM_read_bio:no start line:pem_lib.c:703:Expecting: CERTIFICATE

2015-08-26 07:18:50 ERROR otopi.context context._executeMethod:164 Failed to execute stage 'Environment customization': 140434694452992:error:0906D06C:PEM routines:PEM_read_bio:no start line:pem_lib.c:703:Expecting: CERTIFICATE
...
Comment 2 Alon Bar-Lev 2015-08-29 12:58:12 EDT
I just wonder when will we stop opening downstream bugs when we have only on product and all bugs are result from this single product.

Also qa logs are not secret, should not be applied as private.

*** This bug has been marked as a duplicate of bug 1255638 ***

Note You need to log in before you can comment on or make changes to this bug.