Bug 1255808 - [engine-setup] PKI CONFIGURATION points to upstream wiki about certificates renewal info
[engine-setup] PKI CONFIGURATION points to upstream wiki about certificates r...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.4
Unspecified Unspecified
high Severity low
: ovirt-3.6.1
: 3.6.1
Assigned To: Yedidyah Bar David
Jiri Belka
: ZStream
Depends On:
Blocks: 1275162
  Show dependency treegraph
 
Reported: 2015-08-21 11:33 EDT by Jiri Belka
Modified: 2016-03-09 16:12 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1275162 (view as bug list)
Environment:
Last Closed: 2016-03-09 16:12:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45767 master MERGED packaging: setup: Make pki renewal doc url customizable Never
oVirt gerrit 47713 ovirt-engine-3.5 MERGED packaging: setup: Make pki renewal doc url customizable Never
oVirt gerrit 47725 ovirt-engine-3.6 MERGED packaging: setup: Make pki renewal doc url customizable Never

  None (edit)
Description Jiri Belka 2015-08-21 11:33:25 EDT
Description of problem:

PKI CONFIGURATION points to upstream wiki about certificates renewal info, seems odd.

[ INFO  ] iptables will be configured as firewall manager.
         
          --== DATABASE CONFIGURATION ==--
         
         
          --== OVIRT ENGINE CONFIGURATION ==--
         
          Skipping storing options as database already prepared
         
          --== PKI CONFIGURATION ==--
         
          One or more of the certificates should be renewed, because they expire soon or include an invalid expiry date, which is rejected by recent browsers.
          If you choose "No", you will be asked again the next time you run Setup.
          See http://www.ovirt.org/OVirt_3.5.3_Release_Notes#PKI for more details.
          Renew certificates? (Yes, No) [No]:

/usr/share/ovirt-engine/setup/plugins/ovirt-engine-setup/ovirt-engine/pki/ca.py
...
   441                  ] = dialog.queryBoolean(
   442                      dialog=self.dialog,
   443                      name='OVESETUP_RENEW_PKI',
   444                      note=_(
   445                          'One or more of the certificates should be renewed, '
   446                          'because they expire soon or include an invalid '
   447                          'expiry date, which is rejected by recent browsers.\n'
   448                          'If you choose "No", you will be asked again the next '
   449                          'time you run Setup.\n'
   450                          'See {url} for more details.\n'
   451                          'Renew certificates? '
   452                          '(@VALUES@) [@DEFAULT@]: '
   453                      ).format(
   454                          url=(
   455                              'http://www.ovirt.org/OVirt_3.5.3_Release_Notes'
   456                              '#PKI'


Version-Release number of selected component (if applicable):
rhevm-setup-plugin-ovirt-engine-3.5.4.2-1.3.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. have d/s and see where it points for info about PKI issues
2.
3.

Actual results:
upstream

Expected results:
d/s KB ? no idea...

Additional info:
# fgrep -lIR www.ovirt.org /usr/share/ovirt-engine | grep -v \.war
/usr/share/ovirt-engine/branding/ovirt.brand/external_resources.properties
/usr/share/ovirt-engine/setup/plugins/ovirt-engine-setup/ovirt-engine/pki/ca.py
/usr/share/ovirt-engine/setup/plugins/ovirt-engine-setup/websocket_proxy/pki.py
/usr/share/ovirt-engine/setup/plugins/ovirt-engine-rename/ovirt-engine/pki.py
/usr/share/ovirt-engine/setup/plugins/ovirt-engine-rename/ovirt-engine/misc.py
/usr/share/ovirt-engine/bin/engine-backup.sh
Comment 2 Jiri Belka 2015-12-02 06:56:46 EST
ok, rhevm-setup-base-3.6.1-0.2.el6.noarch

          --== PKI CONFIGURATION ==--
         
          One or more of the certificates should be renewed, because they expire soon or include an invalid expiry date, which is rejected by recent browsers.
          If you choose "No", you will be asked again the next time you run Setup.
          See https://access.redhat.com/solutions/1572983 for more details.
          Renew certificates? (Yes, No) [No]:
Comment 5 errata-xmlrpc 2016-03-09 16:12:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html

Note You need to log in before you can comment on or make changes to this bug.