Bug 1255827 - [RH-COMMON] FAILED assert(m_seed < old_pg_num) in librbd when increasing placement groups
[RH-COMMON] FAILED assert(m_seed < old_pg_num) in librbd when increasing plac...
Status: CLOSED WONTFIX
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD (Show other bugs)
1.2.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.2.4
Assigned To: Josh Durgin
ceph-qe-bugs
: Reopened
Depends On: 1271774
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-21 12:12 EDT by Jason Dillaman
Modified: 2017-07-30 11:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1255830 (view as bug list)
Environment:
Last Closed: 2015-12-08 11:27:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 10399 None None None Never

  None (edit)
Description Jason Dillaman 2015-08-21 12:12:04 EDT
Description of problem:
If librbd has an image opened and the image header's placement group is split (via increasing the number of placement groups), librbd will crash due to a failed assertion.

Version-Release number of selected component (if applicable):
ceph-0.80.8-16

How reproducible:
100%

Steps to Reproduce:
1. create a pool 'test' with 8 pgs
2. rbd create --pool test --image-format 1 --size 1024 foo
3. rbd watch --pool test foo
4. ceph osd pool set test pg_num 16

Actual results:
FAILED assert(m_seed < old_pg_num)

Expected results:
librbd transparently handles the PG increase.

Additional info:
Comment 2 Jason Dillaman 2015-08-21 12:23:39 EDT
Technically -- will only fail if the "RBD header's placement hash" module "old PG count mask" != "RBD header's placement hash" modulo "new PG count mask".  Therefore, the larger the increase in PG count (i.e. double the size), the more likely you will encounter the issue.
Comment 3 Ken Dreyer (Red Hat) 2015-09-01 14:15:11 EDT
Jason and Josh, I'm thinking this bug is a duplicate of bug 1258625. Do you agree?
Comment 4 Josh Durgin 2015-09-01 14:27:35 EDT
Yeah, same bug. Close whichever is convenient.
Comment 5 Ken Dreyer (Red Hat) 2015-09-01 14:32:26 EDT
Thanks! closing this one, since 1258625 has more people on the CC and the customer portal cases attached.

*** This bug has been marked as a duplicate of bug 1258625 ***
Comment 6 Ken Dreyer (Red Hat) 2015-09-02 22:36:42 EDT
On second thought, we'll need this BZ in order to track the librbd fix in RH-COMMON.
Comment 7 Ken Dreyer (Red Hat) 2015-12-08 11:27:53 EST
Closing all RHCS 1.2 bugs, since we are not planning to do a formal RHCS 1.2.4 release.

This particular issue was already fixed in RHCS 1.3, in https://bugzilla.redhat.com/show_bug.cgi?id=1255830

Note You need to log in before you can comment on or make changes to this bug.