Bug 1255890 - qt5 is at 5.5.0, PyQt5 is at 5.4.2
qt5 is at 5.5.0, PyQt5 is at 5.4.2
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-qt5 (Show other bugs)
22
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 1293873 (view as bug list)
Depends On:
Blocks: qt-5.5
  Show dependency treegraph
 
Reported: 2015-08-21 15:26 EDT by Jeff
Modified: 2015-12-23 10:48 EST (History)
12 users (show)

See Also:
Fixed In Version: 2.35.0-1.fc22.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-01 08:19:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff 2015-08-21 15:26:23 EDT
Description of problem:

Qt5 version 5.5.0 was released as an update recently in Fedora 22, PyQt5 is still at version 5.4.2 which does not officially support Qt5.5.0 and it is introducing various subtle bugs into PyQt5 applications.  PyQt5 should be updated to a new 5.x version synchronously with Qt5, and the dependency with PyQt should be considered with any update to Qt.


Version-Release number of selected component (if applicable):

See above

How reproducible:

I think that "PyQt5 version 5.5.0 adds official support for Qt5 version 5.5.0" is adequate reason to fix, but I can provide (somewhat complicated) steps to show that it is causing real problems.

Steps to Reproduce:

N/A, see above

Actual results:

The update to Qt5.5.0 breaks PyQt applications

Expected results:

The update to Qt5.5.0 doesn't break PyQt applications

Additional info:

N/A
Comment 1 Raphael Groner 2015-08-25 06:08:14 EDT
As Qt5.5 is now officially in Fedora 22, I'll raise severity here cause PyQt5's package functionality is now b0rken.
Comment 2 Raphael Groner 2015-08-25 07:36:54 EDT
What package provides PyQt5? I see the pyqt3 and pyqt4 packages, but none that indicates PyQt5 support.
Comment 3 Rex Dieter 2015-08-25 08:12:14 EDT
Working on it (python-qt5 update)
Comment 4 Fedora Update System 2015-08-25 12:22:39 EDT
calibre-2.35.0-1.fc22.1 python-qt5-5.5-1.fc22 PyQt4-4.11.4-1.fc22 sip-4.16.9-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14262
Comment 5 Rex Dieter 2015-08-25 12:46:25 EDT
Do you have any examples of where qt-5.5 breaks PyQt5 applications?  I tried several examples from python-qt5-doc-5.4.2 and they all still ran fine.
Comment 6 Fedora Update System 2015-08-26 13:27:05 EDT
PyQt4-4.11.4-1.fc22, calibre-2.35.0-1.fc22.1, python-qt5-5.5-1.fc22, sip-4.16.9-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update sip PyQt4 python-qt5 calibre'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14262
Comment 7 Stefan Becker 2015-08-30 02:03:18 EDT
F.ex. Calibre ebook-convert failed:

  converting...
  1% Converting input to HTML...
  InputFormatPlugin: HTML Input running
  ...
  Creating MOBI 6 output
  Applying case-transforming CSS...
  This application failed to start because it could not find or load the Qt platform plugin "headless".
  
  Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.
  
  Reinstalling the application may fix this problem.
  conversion failed: Inappropriate ioctl for device

After installing the update the problem is gone. Thanks for the fast fix.
Comment 8 Jeff 2015-08-31 10:54:04 EDT
(In reply to Rex Dieter from comment #5)
> Do you have any examples of where qt-5.5 breaks PyQt5 applications?  I tried
> several examples from python-qt5-doc-5.4.2 and they all still ran fine.

Sorry for the delayed reply, I've been on vacation.  The good news is that the python3-qt5 testing update seems to fix the problem in the testing I've done so far.

The major problem that I can more-or-less directly correlate to PyQt5.4.x with Qt5.5.0 is subtle strange behavior with mouse events in QGraphicsScene/QGraphicsView/QGraphicsItem, if the examples you tested didn't use it QGraphicsItems with mouse events, then you may not have encountered it.  I believe this is because of some changes to AbstractItemModel.

My application reproduces the issue when PyQt5 and Qt5 versions are mismatched, it's just a matter of doing enough clicking and/or dragging on the QGraphicsItems:

https://copr.fedoraproject.org/coprs/musikernel/musikernel/
Comment 9 Fedora Update System 2015-09-01 08:18:58 EDT
PyQt4-4.11.4-1.fc22, calibre-2.35.0-1.fc22.1, python-qt5-5.5-1.fc22, sip-4.16.9-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Rex Dieter 2015-12-23 10:48:43 EST
*** Bug 1293873 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.