Bug 1293873 - dated packages
dated packages
Status: CLOSED DUPLICATE of bug 1255890
Product: Fedora
Classification: Fedora
Component: PyQt (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 05:29 EST by Richard Jasmin
Modified: 2015-12-23 12:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-23 10:48:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Jasmin 2015-12-23 05:29:13 EST
Description of problem:
We should be at version 5.5.1. Anything else is far too dated to be useful.The fact that packages from these versions of QT are installable says a lot about package pruning, because these versions of QT 3/4 are NOT INSTALLABLE. Only version 5 is. Merge to python 3 would be reccommended, but is not forced, yet. Certain apps require this dependency resolved, but this is unresolvable since the package version is only available upstream, and not in the repo.
I would re pack if I knew how.
*distribution bug*

Version-Release number of selected component (if applicable):
22

How reproducible:
always

Steps to Reproduce:
n/a -- not installable, must use the source, luke.

Actual results:
??

Expected results:
version match

Additional info:
DupeGuru points out the flaw on github, but that app has some issues and wont build.

http://pyqt.sourceforge.net/Docs/PyQt5/installation.html
Yes, the links are valid UPSTREAM from distributor.They threw me off at first. Y python team or QT/Nokia doesnt code this, I dont know.
Comment 1 Rex Dieter 2015-12-23 10:48:43 EST
5.5.1 should already be available as part of updates from ~1 month ago:

https://bodhi.fedoraproject.org/updates/FEDORA-2015-3c671e20a3

and prior to that, update to 5.5,
https://bodhi.fedoraproject.org/updates/FEDORA-2015-14262

*** This bug has been marked as a duplicate of bug 1255890 ***
Comment 2 Rex Dieter 2015-12-23 10:49:49 EST
Further, I'm not sure why you say these are not installable,

dnf install PyQt PyQt4 python-qt5

should all work.

If not, please mention how that does work for you, thanks.
Comment 3 Rex Dieter 2015-12-23 12:45:52 EST
oh, and if you want python3 bindings:

dnf install python3-qt5

Note You need to log in before you can comment on or make changes to this bug.