Bug 125594 - VIA Soundcard detected, but distorted sound
VIA Soundcard detected, but distorted sound
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 125602 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-09 03:02 EDT by Holger Koch
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-10 02:04:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Holger Koch 2004-06-09 03:02:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I installed FC-2 x86_64 on my Laptop ( AMD Mobile Athlon64 (2800+ 
MHz, 1 MByte L2-Cache), VIA K8T800, VIA 
Technologies|VT8233/A/8235/8237 AC97 Audio Controller).

After Reboot, all looks good. The module snd_mixer_oss, 
snd_via82xx,snd_pcm,snd_timer,snd_ac97_codec,snd_mpu401_uart,snd_rawmi
di,snd_seq_device are loaded.

When i run "soundcard detection", i see my soundcard and the Modul: 
snd-via82xx. But if i play the "test sound", i hear the sound absolut 
distorted. It played a small part of the sound and then loop the end. 
Then play the next part and loop again, and so on. 

The top command shows me, that at the moment i start the "test 
sound", the cpu load grows rapid. Before, the cpu is idle at 99%. 
During the test sound, i have nearly 20% user Load and 70%wa, nearly 
0% idle. So i think, there is no more CPU to play the test sound, no 
data are transmitted to the soundcard and so the sound loops.

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358

How reproducible:
Always

Steps to Reproduce:
1.start of fedora runlevel 5
2.run "soundcard detection"
3.play testsound
    

Actual Results:  i hear crazy sound and the cpu is under heavy load.

Additional info:
Comment 1 Holger Koch 2004-06-09 04:59:18 EDT
*** Bug 125602 has been marked as a duplicate of this bug. ***
Comment 2 Holger Koch 2004-06-09 12:24:25 EDT
After i add the kernelparameter acpi=off, the sound works fine. In 
the /var/log/messages i found an entry 
ACPI-0179: *** Warning: The ACPI AML in your computer contains 
errors, please nag the manufacturer to correct it.
ACPI-0182: *** Warning: Allowing relaxed access to fields; turn on 
CONFIG_ACPI_DEBUG for details.

Can be this the problem?
Comment 3 Len Brown 2004-06-09 23:45:46 EDT
please attach the complete dmesg and /proc/interrupts from the two cases -- 
with and without acpi=off. 
Comment 4 Holger Koch 2004-06-10 02:03:28 EDT
the problem is the same as in bug #125592. Please see there for 
further information.

best regards

Holger Koch

Note You need to log in before you can comment on or make changes to this bug.