Bug 1256049 - [Cinder] Commit a previewed snapshot with Cinder disk should remove orphaned disks
[Cinder] Commit a previewed snapshot with Cinder disk should remove orphaned ...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity high (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: Maor
Natalie Gavrielov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-23 12:32 EDT by Maor
Modified: 2016-03-10 10:16 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 08:32:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.z?
ylavi: planning_ack+
amureini: devel_ack+
ylavi: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48937 master MERGED core: Add Cinder helper method for candidate volumes to delete. Never
oVirt gerrit 48938 master MERGED core: Add updateSnapshot to CinderDiskParameters. Never
oVirt gerrit 48939 master MERGED core: Use linked list instead of list. Never
oVirt gerrit 48940 master MERGED core: Add a new Cinder volume parent command. Never
oVirt gerrit 48941 master MERGED core: Restore snapshot should handle Cinder snapshot. Never
oVirt gerrit 48942 master MERGED core: Refactor, Use RemoveCinderVolumeParentCommand method. Never
oVirt gerrit 48943 master ABANDONED core: Refactor, use getDisk at RemoveCinderDiskCommand. Never
oVirt gerrit 48944 master ABANDONED core: Refactor, clear all parent methods from child command. Never
oVirt gerrit 49413 master MERGED core: Get initial Cinder volume to restore from. Never
oVirt gerrit 49414 master MERGED core: Get previewed snapshot's images by the snapshot's OVF. Never
oVirt gerrit 49415 master MERGED core: Handle Cinder imaged once snapshot gets commited/undo. Never
oVirt gerrit 49417 master MERGED core: Rename parameter cinderDisks to cinderDisksToRestore. Never
oVirt gerrit 49418 master MERGED core: before unlock a VM, fetch it from the DB Never
oVirt gerrit 49419 master MERGED core: RestoreCinderSnapshot should delete volumes by order. Never
oVirt gerrit 49420 master MERGED core: Re-factor restore snapshot for Cinder disks. Never
oVirt gerrit 49421 master MERGED core: Remove redundant Cinder volumes for commited snapshot. Never
oVirt gerrit 49422 master MERGED core: cleanup RestoreFromSnapshotParameters from Cinder. Never
oVirt gerrit 49428 master MERGED core: Add cinder volume type for VM's disks' OVF. Never
oVirt gerrit 49685 master MERGED core: cleanup, use getDiskImageDao at isCinderHasNoImages. Never
oVirt gerrit 50054 ovirt-engine-3.6 MERGED core: Add Cinder helper method for candidate volumes to delete. Never
oVirt gerrit 50055 ovirt-engine-3.6 MERGED core: cleanup, use getDiskImageDao at isCinderHasNoImages. Never
oVirt gerrit 50056 ovirt-engine-3.6 MERGED core: Add updateSnapshot to CinderDiskParameters. Never
oVirt gerrit 50057 ovirt-engine-3.6 MERGED core: Use linked list instead of list. Never
oVirt gerrit 50058 ovirt-engine-3.6 MERGED core: Add a new Cinder volume parent command. Never
oVirt gerrit 50060 ovirt-engine-3.6 MERGED core: Refactor, Use RemoveCinderVolumeParentCommand method. Never
oVirt gerrit 50061 ovirt-engine-3.6 MERGED core: Get initial Cinder volume to restore from. Never
oVirt gerrit 50062 ovirt-engine-3.6 MERGED core: Add cinder volume type for VM's disks' OVF. Never
oVirt gerrit 50063 ovirt-engine-3.6 MERGED core: Get previewed snapshot's images by the snapshot's OVF. Never
oVirt gerrit 50064 ovirt-engine-3.6 MERGED core: Handle Cinder imaged once snapshot gets commited/undo. Never
oVirt gerrit 50065 ovirt-engine-3.6 MERGED core: Rename parameter cinderDisks to cinderDisksToRestore. Never
oVirt gerrit 50066 ovirt-engine-3.6 MERGED core: before unlock a VM, fetch it from the DB Never
oVirt gerrit 50067 ovirt-engine-3.6 MERGED core: RestoreCinderSnapshot should delete volumes by order. Never
oVirt gerrit 50068 ovirt-engine-3.6 MERGED core: Re-factor restore snapshot for Cinder disks. Never
oVirt gerrit 50069 ovirt-engine-3.6 MERGED core: Remove redundant Cinder volumes for commited snapshot. Never
oVirt gerrit 50070 ovirt-engine-3.6 MERGED core: cleanup RestoreFromSnapshotParameters from Cinder. Never
oVirt gerrit 50781 ovirt-engine-3.6 MERGED core: Fetch cinder disk with for loop when committing a snapshot. 2015-12-21 05:22 EST

  None (edit)
Description Maor 2015-08-23 12:32:30 EDT
Description of problem:
Commit a previewed snapshot with Cinder disk which has orphaned active cinder disks before the preview operation, does not delete all the orphaned disk after the snapshot gets committed.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Create a VM with Cinder disk
2. Create a snapshot (Lets call it snapshot A)
3. Create another snapshot (Lets call it snapshot B)
4. Create another snapshot (Lets call it snapshot C)
5. Create a new Cinder disk. (Lets call it latest_cinder_disk)
5. preview snapshot A
6. Commit the previewed snapshot

Actual results:
latest_cinder_disk does not get deleted.

Expected results:
latest_cinder_disk should be deleted from Cinder

Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:58:40 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Yaniv Lavi 2015-10-29 08:31:00 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 3 Sandro Bonazzola 2015-12-23 08:42:55 EST
oVirt 3.6.2 RC1 has been released for testing, moving to ON_QA

Note You need to log in before you can comment on or make changes to this bug.