Bug 1256225 - [abrt] puddletag: puddleobjects.py:1420:__init__:TypeError: QBrush(): argument 1 has unexpected type 'ColorRole'
[abrt] puddletag: puddleobjects.py:1420:__init__:TypeError: QBrush(): argumen...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: puddletag (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Terje Røsten
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:ae8014dac85fd11dd3f01573501...
:
: 1262592 1265000 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 02:12 EDT by idviare
Modified: 2015-10-03 17:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.0.5-3.fc22 puddletag-1.0.5-3.fc23 puddletag-1.0.5-3.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 18:53:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.26 KB, text/plain)
2015-08-24 02:12 EDT, idviare
no flags Details
File: environ (1.31 KB, text/plain)
2015-08-24 02:12 EDT, idviare
no flags Details

  None (edit)
Description idviare 2015-08-24 02:12:51 EDT
Description of problem:
Puddletag never open, abrt give me the warning, so i've decided run puddletag from terminal and the output is in the report.

Version-Release number of selected component:
puddletag-1.0.5-2.fc23

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python2 /usr/bin/puddletag
executable:     /usr/bin/puddletag
kernel:         3.19.7-200.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            1001

Truncated backtrace:
puddleobjects.py:1420:__init__:TypeError: QBrush(): argument 1 has unexpected type 'ColorRole'

Traceback (most recent call last):
  File "/usr/bin/puddletag", line 350, in <module>
    win = MainWin()
  File "/usr/lib/python2.7/site-packages/puddlestuff/puddletag.py", line 314, in __init__
    winactions, self._docks = create_tool_windows(self)
  File "/usr/lib/python2.7/site-packages/puddlestuff/puddletag.py", line 91, in create_tool_windows
    p = PuddleDock(z[0], z[1], parent, status)
  File "/usr/lib/python2.7/site-packages/puddlestuff/puddleobjects.py", line 2192, in __init__
    control = control(status=status)
  File "/usr/lib/python2.7/site-packages/puddlestuff/mainwin/artwork.py", line 61, in __init__
    self.picwidget = PicWidget()
  File "/usr/lib/python2.7/site-packages/puddlestuff/puddleobjects.py", line 1529, in __init__
    self.label = ArtworkLabel()
  File "/usr/lib/python2.7/site-packages/puddlestuff/puddleobjects.py", line 1420, in __init__
    pal.setBrush(self.backgroundRole(), QBrush(QPalette.Window))
TypeError: QBrush(): argument 1 has unexpected type 'ColorRole'

Local variables in innermost frame:
self: <puddlestuff.puddleobjects.ArtworkLabel object at 0x7fb54191f218>
args: ()
pal: <PyQt4.QtGui.QPalette object at 0x7fb541911488>
kwargs: {}
Comment 1 idviare 2015-08-24 02:12:54 EDT
Created attachment 1066213 [details]
File: backtrace
Comment 2 idviare 2015-08-24 02:12:55 EDT
Created attachment 1066214 [details]
File: environ
Comment 3 Terje Røsten 2015-09-20 09:42:15 EDT
*** Bug 1262592 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2015-09-20 10:28:33 EDT
puddletag-1.0.5-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16236
Comment 5 Fedora Update System 2015-09-20 10:28:39 EDT
puddletag-1.0.5-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16237
Comment 6 Fedora Update System 2015-09-20 12:49:50 EDT
puddletag-1.0.5-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update puddletag'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16237
Comment 7 Fedora Update System 2015-09-20 12:51:51 EDT
puddletag-1.0.5-3.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update puddletag'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16235
Comment 8 Fedora Update System 2015-09-20 13:20:16 EDT
puddletag-1.0.5-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update puddletag'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16236
Comment 9 Jeremy Newton 2015-09-21 19:07:25 EDT
*** Bug 1265000 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2015-09-22 18:53:27 EDT
puddletag-1.0.5-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2015-10-03 13:53:57 EDT
puddletag-1.0.5-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2015-10-03 17:52:36 EDT
puddletag-1.0.5-3.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.