Bug 1262592 - [abrt] puddletag: puddleobjects.py:1420:__init__:TypeError: QBrush(): argument 1 has unexpected type 'ColorRole'
[abrt] puddletag: puddleobjects.py:1420:__init__:TypeError: QBrush(): argumen...
Status: CLOSED DUPLICATE of bug 1256225
Product: Fedora
Classification: Fedora
Component: puddletag (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Terje Røsten
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:ae8014dac85fd11dd3f01573501...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-13 02:02 EDT by Dan Ziemba
Modified: 2015-09-20 09:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-20 09:42:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.26 KB, text/plain)
2015-09-13 02:02 EDT, Dan Ziemba
no flags Details
File: environ (8.75 KB, text/plain)
2015-09-13 02:02 EDT, Dan Ziemba
no flags Details

  None (edit)
Description Dan Ziemba 2015-09-13 02:02:08 EDT
Description of problem:
Program crashes imediately on start.

Version-Release number of selected component:
puddletag-1.0.5-1.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python2 /usr/bin/puddletag
executable:     /usr/bin/puddletag
kernel:         4.1.6-201.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
puddleobjects.py:1420:__init__:TypeError: QBrush(): argument 1 has unexpected type 'ColorRole'

Traceback (most recent call last):
  File "/usr/bin/puddletag", line 350, in <module>
    win = MainWin()
  File "/usr/lib/python2.7/site-packages/puddlestuff/puddletag.py", line 314, in __init__
    winactions, self._docks = create_tool_windows(self)
  File "/usr/lib/python2.7/site-packages/puddlestuff/puddletag.py", line 91, in create_tool_windows
    p = PuddleDock(z[0], z[1], parent, status)
  File "/usr/lib/python2.7/site-packages/puddlestuff/puddleobjects.py", line 2192, in __init__
    control = control(status=status)
  File "/usr/lib/python2.7/site-packages/puddlestuff/mainwin/artwork.py", line 61, in __init__
    self.picwidget = PicWidget()
  File "/usr/lib/python2.7/site-packages/puddlestuff/puddleobjects.py", line 1529, in __init__
    self.label = ArtworkLabel()
  File "/usr/lib/python2.7/site-packages/puddlestuff/puddleobjects.py", line 1420, in __init__
    pal.setBrush(self.backgroundRole(), QBrush(QPalette.Window))
TypeError: QBrush(): argument 1 has unexpected type 'ColorRole'

Local variables in innermost frame:
self: <puddlestuff.puddleobjects.ArtworkLabel object at 0x7fe81f3893e0>
args: ()
pal: <PyQt4.QtGui.QPalette object at 0x7fe81f37df50>
kwargs: {}

Potential duplicate: bug 1256225
Comment 1 Dan Ziemba 2015-09-13 02:02:10 EDT
Created attachment 1072815 [details]
File: backtrace
Comment 2 Dan Ziemba 2015-09-13 02:02:11 EDT
Created attachment 1072816 [details]
File: environ
Comment 3 Terje Røsten 2015-09-20 09:42:15 EDT

*** This bug has been marked as a duplicate of bug 1256225 ***

Note You need to log in before you can comment on or make changes to this bug.