This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1256238 - Scheduler fails when policy filters is null
Scheduler fails when policy filters is null
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ovirt-3.6.2
: 3.6.0
Assigned To: Roy Golan
Artyom
: Triaged
: 1276380 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 03:04 EDT by Dudi Maroshi
Modified: 2016-04-19 21:28 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:28:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44610 master MERGED core: fix NPE on scheduler when policy filters is null Never
oVirt gerrit 45235 ovirt-engine-3.6 ABANDONED core: fix NPE on scheduler when policy filters is null Never
oVirt gerrit 48302 ovirt-engine-3.6 MERGED core: fix NPE on scheduler when policy filters is null Never

  None (edit)
Description Dudi Maroshi 2015-08-24 03:04:25 EDT
Description of problem:
When there are no policies in the scheduling policies.
Running a VM or migrating a VM fails.


Version-Release number of selected component (if applicable):
3.6


How reproducible:
1. Create a new scheduling policy.
2. Remove any filter from the empty-scheduling policy.
3. Save empty-scheduling policy.
4. Create a new cluster.
5. Apply empty-scheduling to cluster.
6. Try run a VM on the new cluster. 

Actual results:
Run VM operation fails.
engine.log report null pointer exception in SchedulingManger.java
Comment 1 Sandro Bonazzola 2015-10-26 08:50:01 EDT
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high
Comment 2 Martin Betak 2015-11-24 06:41:55 EST
*** Bug 1276380 has been marked as a duplicate of this bug. ***
Comment 3 Eyal Edri 2015-12-17 08:57:50 EST
RHEV 3.6.0 BETA2 is out, any open bugs are moved to the BETA3 milestone.
Comment 4 Artyom 2015-12-27 09:22:23 EST
Verified on rhevm-3.6.2-0.1.el6.noarch
1) Create new empty cluster policy
2) Attach new policy to cluster
3) Start vm
4) Migrate vm
succeed

Note You need to log in before you can comment on or make changes to this bug.