Bug 1276380 - NPE while running a VM with passthrough devices
NPE while running a VM with passthrough devices
Status: CLOSED DUPLICATE of bug 1256238
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.2
: ---
Assigned To: Martin Betak
Ilanit Stein
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 10:53 EDT by Michal Skrivanek
Modified: 2016-02-10 14:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 06:41:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michal.skrivanek: ovirt‑3.6.z?
michal.skrivanek: ovirt‑4.0.0?
michal.skrivanek: planning_ack?
michal.skrivanek: devel_ack?
michal.skrivanek: testing_ack?


Attachments (Terms of Use)
engine.log (2.02 MB, text/plain)
2015-10-29 10:53 EDT, Michal Skrivanek
no flags Details

  None (edit)
Description Michal Skrivanek 2015-10-29 10:53:56 EDT
Created attachment 1087581 [details]
engine.log

I was playing with UI and found an issue when removing assigned devices. NPE in the log and weird behavior

Time: 2015-10-24 09:05:02,871
I had a VM with several devices assigned and only one host (not properly configured for passthrough) and tried to Run it

Time: 2015-10-24 09:06:05,921 and around:
Then I tried to remove the devices (not all at once, in 3 steps) and during the removal of the last one I received an empty result, device disappeared from the UI but apparently remained in backend - after switching tabs the device was still there
Comment 1 Michal Skrivanek 2015-10-29 11:11:36 EDT
seems it left the VM in some inconsistent state as it can't be run ever again even when all devices are removed and engine is restarted
Comment 2 Martin Betak 2015-11-24 06:41:55 EST
The issue of failing to run the VM has already been fixed in 3.6. Marking as duplicate.

The '[]' in devices removed may appear in cases when you issue the remove commands too quickly and the device has already been removed as a result of previous bulk command. In that case the second operation is NO-OP thus resulting in "empty list of devices has been removed" message.

*** This bug has been marked as a duplicate of bug 1256238 ***

Note You need to log in before you can comment on or make changes to this bug.