This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1256243 - remove-brick: avoid mknod op falling on decommissioned brick even after fix-layout has happened on parent directory
remove-brick: avoid mknod op falling on decommissioned brick even after fix-l...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Susant Kumar Palai
:
Depends On:
Blocks: 1256702
  Show dependency treegraph
 
Reported: 2015-08-24 03:17 EDT by Susant Kumar Palai
Modified: 2016-06-16 09:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1256702 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:33:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Susant Kumar Palai 2015-08-24 03:17:32 EDT
Description of problem:
Because of stale-layout issue, a mknod op may fall on decommissioned brick even after the parent layout is fixed.

Version-Release number of selected component (if applicable):


How reproducible:
Quite frequent with nfs mount 

Steps to Reproduce:
1. create distribute volume with more than one brick
2. remove one of the brick
3. post remove-brick do large number of mknod call. 


Actual results:
Some files are left on the removed-brick post remove-brick commit.
Comment 1 Anand Avati 2015-08-25 04:53:51 EDT
COMMIT: http://review.gluster.org/11998 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 90c7c30c3aa9417793ae972b2b9051bc5200e7e4
Author: Susant Palai <spalai@redhat.com>
Date:   Mon Aug 24 03:04:41 2015 -0400

    cluster/dht: avoid mknod on decommissioned brick
    
    Change-Id: I8c39ce38e257758e27e11ccaaff4798138203e0c
    BUG: 1256243
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/11998
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 2 Kaleb KEITHLEY 2015-10-22 13:00:12 EDT
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.
Comment 3 Kaleb KEITHLEY 2015-10-22 13:06:51 EDT
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.
Comment 4 Kaleb KEITHLEY 2015-10-22 13:11:18 EDT
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.
Comment 5 Niels de Vos 2016-06-16 09:33:12 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.