Bug 1256702 - remove-brick: avoid mknod op falling on decommissioned brick even after fix-layout has happened on parent directory
remove-brick: avoid mknod op falling on decommissioned brick even after fix-l...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Susant Kumar Palai
:
Depends On: 1256243
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 05:54 EDT by Susant Kumar Palai
Modified: 2015-09-09 05:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1256243
Environment:
Last Closed: 2015-09-09 05:40:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Susant Kumar Palai 2015-08-25 05:54:09 EDT
+++ This bug was initially created as a clone of Bug #1256243 +++

Description of problem:
Because of stale-layout issue, a mknod op may fall on decommissioned brick even after the parent layout is fixed.

Version-Release number of selected component (if applicable):


How reproducible:
Quite frequent with nfs mount 

Steps to Reproduce:
1. create distribute volume with more than one brick
2. remove one of the brick
3. post remove-brick do large number of mknod call. 


Actual results:
Some files are left on the removed-brick post remove-brick commit.

--- Additional comment from Anand Avati on 2015-08-25 13:53:51 MVT ---

COMMIT: http://review.gluster.org/11998 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 90c7c30c3aa9417793ae972b2b9051bc5200e7e4
Author: Susant Palai <spalai@redhat.com>
Date:   Mon Aug 24 03:04:41 2015 -0400

    cluster/dht: avoid mknod on decommissioned brick
    
    Change-Id: I8c39ce38e257758e27e11ccaaff4798138203e0c
    BUG: 1256243
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/11998
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 1 Anand Avati 2015-08-27 03:42:55 EDT
REVIEW: http://review.gluster.org/12024 (cluster/dht: avoid mknod on decommissioned brick) posted (#1) for review on release-3.7 by Susant Palai (spalai@redhat.com)
Comment 2 Anand Avati 2015-08-27 09:28:02 EDT
COMMIT: http://review.gluster.org/12024 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 315edb7868fd3a726c9c99a2ce710f8421440a65
Author: Susant Palai <spalai@redhat.com>
Date:   Mon Aug 24 03:04:41 2015 -0400

    cluster/dht: avoid mknod on decommissioned brick
    
    BUG: 1256702
    Change-Id: I0795720cb77a9c77e608f34fbb69574fd2acb542
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/11998
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/12024
Comment 3 Kaushal 2015-09-09 05:40:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.