Bug 1256283 - [remove-brick]: Creation of file from NFS writes to the decommissioned subvolume and subsequent lookup from fuse creates a link
[remove-brick]: Creation of file from NFS writes to the decommissioned subvo...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
3.7.3
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Susant Kumar Palai
: Triaged
Depends On: 1225452 1232378
Blocks: 1223636 1227687
  Show dependency treegraph
 
Reported: 2015-08-24 05:34 EDT by Susant Kumar Palai
Modified: 2015-09-09 05:40 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1232378
Environment:
Last Closed: 2015-09-09 05:40:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2015-08-24 05:39:55 EDT
REVIEW: http://review.gluster.org/11999 (dht: block/handle create op falling to decommissioned brick) posted (#1) for review on release-3.7 by Susant Palai (spalai@redhat.com)
Comment 2 Anand Avati 2015-08-25 05:58:04 EDT
REVIEW: http://review.gluster.org/12001 (dht: block/handle create op falling to decommissioned brick) posted (#2) for review on release-3.7 by Susant Palai (spalai@redhat.com)
Comment 3 Anand Avati 2015-08-27 00:56:17 EDT
COMMIT: http://review.gluster.org/12001 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 6aa0e72198e83d6dd849027fd3d0038037810065
Author: Susant Palai <spalai@redhat.com>
Date:   Tue Jun 16 20:35:46 2015 +0530

    dht: block/handle create op falling to decommissioned brick
    
    Problem:
    Post remove-brick start till commit phase, the client layout
    may not be in sync with disk layout because of lack of lookup.
    Hence,a create call may fall on the decommissioned brick.
    
    Solution:
    Will acquire a lock on hashed subvol. So that a fix-layout or
    selfheal can not step on layout while reading the layout.
    
    Even if we read a layout before remove-brick fix-layout and the
    file falls on the decommissioned brick, the file should be
    migrated to a new brick as per the fix-layout.
    
    BUG: 1256283
    Change-Id: I3ef1adaf20dfb9524396a3648d1a664464eda8c1
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/11260
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/12001
Comment 4 Kaushal 2015-09-09 05:40:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.