Bug 1256510 - [RFE] Cinder replication V2
[RFE] Cinder replication V2
Status: CLOSED DUPLICATE of bug 1258645
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: Upstream M3
: 9.0 (Mitaka)
Assigned To: Eric Harney
nlevinki
https://blueprints.launchpad.net/cind...
upstream_milestone_liberty-3 upstream...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 15:14 EDT by Sean Cohen
Modified: 2016-04-26 15:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
A new scaled backend replication implementation between backends that leaves the bulk of the work up to the driver, while providing basic admin API methods to do things like enable/disable and fail-over. This first iteration of the new API supports only a single remote device, with limited tenants visibility.
Last Closed: 2015-11-24 06:10:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 200269 None None None Never

  None (edit)
Description Sean Cohen 2015-08-24 15:14:52 EDT
The goal is to take some of the lessons learned from the first version of replication that was added in teh Juno release and make it something that is more widely usable by other backend devices.

This spec proposes a use of our entire tool-box to implement replication.
http://specs.openstack.org/openstack/cinder-specs/specs/liberty/replication_v2.html

    Capabilities - determine if we can even do anything related to replication
    Types/Extra-Specs - provide mechanism for vendor-unique custom info and help level out some of the unique aspects among the different back-ends.
    API Calls - provide some general API calls for things like enable, disable etc
Comment 3 Sergey Gotliv 2015-11-24 06:10:05 EST

*** This bug has been marked as a duplicate of bug 1258645 ***

Note You need to log in before you can comment on or make changes to this bug.