Bug 1258645 - [RFE][cinder] Volume Replication V2
[RFE][cinder] Volume Replication V2
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: beta
: 8.0 (Liberty)
Assigned To: Eric Harney
lkuchlan
http://specs.openstack.org/openstack/...
: FutureFeature
: 1256510 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-31 18:00 EDT by Sean Cohen
Modified: 2016-04-26 11:16 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-cinder-7.0.0-2.el7ost
Doc Type: Enhancement
Doc Text:
This enhancement adds a new scaled backend replication implementation (between backends) that leaves the bulk of the work up to the driver, while providing basic admin API methods. This is available where replication is set at the volume types level, and when the cinder driver reports its capabilities. New configuration options are available: replication_enabled - set to True replication_type - async, sync replication_count - Number of replicas
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:05:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 200269 None None None Never

  None (edit)
Description Sean Cohen 2015-08-31 18:00:42 EDT
This adds a scaled back replication implementation that leaves the bulk of the work up to the driver.
Providing basic admin API methods to do things like enable/disable and fail-over.  Set up and specification of replication targets for a specific
back end are now intended to be part of the cinder.conf in the driver section itself.

https://blueprints.launchpad.net/cinder/+spec/replication-v2
Comment 4 Sergey Gotliv 2015-11-24 06:10:05 EST
*** Bug 1256510 has been marked as a duplicate of this bug. ***
Comment 6 lkuchlan 2016-02-01 07:50:54 EST
Eric, can you provide which drivers support this feature and give a generic example for the configuration?
Comment 9 lkuchlan 2016-04-04 03:56:10 EDT
Since we do not have a relevant driver for volume replication, it was not tested yet. Once we'll have a driver, it will be tested
   
Test plan:
https://polarion.engineering.redhat.com/polarion/#/project/RHELOpenStackPlatform/wiki/Cinder/RFE_1258645-Volume%20Replication%20V2?sidebar=testrun&testrun=LVM%20driver%20-%20over%20subscription%20in%20thin%20provisioning_run_23_11_2015
Comment 11 errata-xmlrpc 2016-04-07 17:05:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.