Bug 1256564 - DELETE_FAILED when trying to delete an already FAILED stack
DELETE_FAILED when trying to delete an already FAILED stack
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity medium
: z2
: 7.0 (Kilo)
Assigned To: Steve Baker
Alexander Chuzhoy
: Triaged, ZStream
: 1242796 1253493 (view as bug list)
Depends On: 1230163
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 20:39 EDT by Steve Baker
Modified: 2016-04-26 15:24 EDT (History)
19 users (show)

See Also:
Fixed In Version: openstack-heat-2015.1.0-6.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the Orchestration service did not take stack action into account when checking the stack state. As a result, deleting a stack in a FAILED state would first cause the stack to go into a DELETE_FAILED status. It took a second delete attempt to actually delete the stack. With this update, the stack action is now taken into account when checking the stack state. Specifically, the current action is now compared with whatever action leads to a reported stack state. As such, stacks in a FAILED state will be correctly deleted on the first attempt. (BZ#1256564)
Story Points: ---
Clone Of: 1230163
Environment:
Last Closed: 2015-10-08 08:20:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Baker 2015-08-24 20:39:23 EDT
+++ This bug was initially created as a clone of Bug #1230163 +++

Description of problem:
When I get CREATE_FAILED in deployments and try to delete the stack - it always ends up in DELETE_FAILED state and I have no work around. I need to reprovision the machine. 

This bug is to track heat fixes for deleting stacks which are already in a FAILED state.
Comment 7 Zane Bitter 2015-09-09 18:07:09 EDT
*** Bug 1242796 has been marked as a duplicate of this bug. ***
Comment 8 Steve Baker 2015-09-09 19:57:32 EDT
*** Bug 1253493 has been marked as a duplicate of this bug. ***
Comment 10 Alexander Chuzhoy 2015-09-29 14:15:10 EDT
Verified:
openstack-heat-common-2015.1.1-5.el7ost.noarch
openstack-heat-api-cfn-2015.1.1-5.el7ost.noarch
openstack-heat-api-cloudwatch-2015.1.1-5.el7ost.noarch
openstack-heat-api-2015.1.1-5.el7ost.noarch
openstack-heat-templates-0-0.6.20150605git.el7ost.noarch
openstack-heat-engine-2015.1.1-5.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-69.el7ost.noarch


Was able to delete the overcloud on a first attempt after a failed attempt to update it (which caused it to appear as failed).
Comment 12 errata-xmlrpc 2015-10-08 08:20:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1865

Note You need to log in before you can comment on or make changes to this bug.