Bug 1256699 - Update to 1.5
Update to 1.5
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: jq (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: hguemar
Fedora Extras Quality Assurance
:
: 1227905 1249874 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 05:48 EDT by Andreas Kohn
Modified: 2015-08-31 23:36 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.5-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 23:36:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch to apply the update. (2.75 KB, application/mbox)
2015-08-25 05:48 EDT, Andreas Kohn
no flags Details

  None (edit)
Description Andreas Kohn 2015-08-25 05:48:29 EDT
Created attachment 1066802 [details]
Proposed patch to apply the update.

Description of problem:
jq in Fedora is on version 1.3, upstream has 1.5 with many changes.

Version-Release number of selected component (if applicable):
1.3

How reproducible:
Always

Steps to Reproduce:
1. Install jq
2. Run jq -V

Actual results:
jq version 1.3

Expected results:
jq-1.5

Additional info:
Update available at https://github.com/ankon/fedora-jq/tree/update-1.5 (forked from http://pkgs.fedoraproject.org/cgit/jq.git/), also attached.

Note that this would fix https://bugzilla.redhat.com/show_bug.cgi?id=1227905 and https://bugzilla.redhat.com/show_bug.cgi?id=1249874
Comment 1 Flavio Percoco 2015-08-25 06:54:36 EDT
*** Bug 1227905 has been marked as a duplicate of this bug. ***
Comment 2 Flavio Percoco 2015-08-25 06:54:52 EDT
*** Bug 1249874 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2015-08-26 11:51:10 EDT
jq-1.5-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14346
Comment 4 Andreas Kohn 2015-08-31 10:36:49 EDT
Given that this was my first submitted update to a package in Fedora, and I see no comments but a different spec in the FEDORA-2015-14346 update I'd like to ask explicitly: Did I do anything specifically wrong, and/or could have done better?
Comment 5 Haïkel Guémar 2015-08-31 12:59:14 EDT
@Andreas: my apologies, I didn't see the attachment when I read my inbox.
I confused it with the upstream release notification.
It's mostly correct, except the Group tags which are now unused in Fedora and EL7
Comment 6 Fedora Update System 2015-08-31 14:53:27 EDT
jq-1.5-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update jq'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14346
Comment 7 Fedora Update System 2015-08-31 23:36:13 EDT
jq-1.5-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.