Bug 1256712 - System freezes after login when monitor is connected to docking station of laptop
System freezes after login when monitor is connected to docking station of la...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
AcceptedBlocker https://fedoraproject...
: CommonBugs
: 1224929 (view as bug list)
Depends On:
Blocks: F23FinalBlocker
  Show dependency treegraph
 
Reported: 2015-08-25 06:13 EDT by Petr Schindler
Modified: 2015-10-29 10:44 EDT (History)
26 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-14 06:44:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of journalctl -a (445.39 KB, text/plain)
2015-08-25 06:24 EDT, Petr Schindler
no flags Details

  None (edit)
Description Petr Schindler 2015-08-25 06:13:06 EDT
Description of problem:
When I boot with a monitor connected to docking station of my Lenovo T540p the system freeze after I log in. Password input works but after I put password and hit enter the system freeze.

I can switch to another tty, but it takes a lot of time and there I see lot of 

[drm:intel_dp_start_link_train [i915]] *ERROR* too many voltage retries, give up

messages. After a while a message 

[drm:intel_dp_complete_link_train [i915]] *ERROR* failed to train DP, aborting

appears and those voltage msgs stops. I can normally log in to terminal. So you can find output of journalctl attached.

When I boot with external monitor connected to laptop's vga port everything works fine (no freezes).

Version-Release number of selected component (if applicable):
It happens with both
kernel-4.2.0-0.rc6.git0.2.fc23.x86_64
kernel-4.2.0-0.rc8.git0.1.fc23.x86_64

How reproducible:
always

Steps to Reproduce:
1. 
2.
3.

Actual results:


Expected results:


Additional info:
I propose this as a beta blocker as it violates the alpha criterion: " A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop using a user account created during installation or a 'first boot' utility. "
Comment 1 Petr Schindler 2015-08-25 06:24:09 EDT
Created attachment 1066815 [details]
output of journalctl -a
Comment 2 Stephen Gallagher 2015-08-31 12:04:55 EDT
I'm experiencing the same issue on my T540p. I will note that dropping back to kernel-4.1.4-200.fc22.x86_64 makes the issue go away, so it's definitely a kernel problem.

(I should also note that I'm having a number of other issues with multi-monitor support in the 4.2.0 series on this hardware; Sometimes it doesn't freeze, but simply fails to detect additional monitors.)
Comment 3 Adam Williamson 2015-08-31 12:38:46 EDT
Discussed at 2015-08-31 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-08-31/f23-blocker-review.2015-08-31-16.01.log.txt . Accepted as a blocker as a conditional violation of the criterion cited in the description - the condition being 'you're using an affected system with an external display'. This system is known to be common in a major Fedora user population (Red Hat staff), so it seems reasonable to consider the impact significant enough to block on.
Comment 4 Ben Breard 2015-08-31 22:27:32 EDT
Same problem here on my t440s w/ the dock. I got excited this morning when I was able to login properly to GNOME w/ 3 monitors properly on f23, but I was unable to wake the screen back up after a few minutes of idle usage. After a hard power down I couldn't login again and had to revert to an 4.1.3 F22 kernel. 

Some logs are here: http://www.fpaste.org/261769/07259014/
Comment 5 Kamil Páral 2015-09-01 04:32:01 EDT
I can't reproduce this with F23 Beta TC1 Live on T450s, Intel Broadwell:
00:02.0 VGA compatible controller [0300]: Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09)

OTOH, Petr found that the he can't even boot the LiveCD, the kernel gets stuck after loading initrd and only a blinking cursor is shown. After undocking it boots fine.
Comment 6 Petr Schindler 2015-09-01 06:07:32 EDT
This bug was probably introduced in 4.2 kernel. I installed the last 4.1 kernel and secondary monitor works fine with docking station.
Comment 7 Stephen Gallagher 2015-09-10 08:28:06 EDT
I'd like to propose that we move this bug to Final Blocker instead of Beta Blocker. I'm not convinced that the problem is sufficiently serious to justify blocking the Beta. The obvious workaround until this is finished is "don't use the dock, just plug in directly".

Also, the engineer who can fix this has been on vacation since Aug. 24th and won't be back until Sept. 14th, making it a guarantee that this bug will cause a slip if left in Blocker status.
Comment 8 Adam Williamson 2015-09-10 15:39:53 EDT
Discussed at 2015-09-10 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-09-10/f23-blocker-review.2015-09-10-16.00.log.txt . On re-consideration we agreed that the impact here is not really severe enough to block Beta; Final blocker is more appropriate. This will be documented for Beta.
Comment 9 Dave Airlie 2015-09-22 03:48:27 EDT
this does appear to be fixed upstream, so I'm trying to ascertain where it got fixed and get it into 4.2.x
Comment 10 Kamil Páral 2015-10-02 04:31:26 EDT
*** Bug 1224929 has been marked as a duplicate of this bug. ***
Comment 11 Ondrej Holy 2015-10-02 05:38:36 EDT
(In reply to Dave Airlie from comment #9)
> this does appear to be fixed upstream, so I'm trying to ascertain where it
> got fixed and get it into 4.2.x

FYI kernel-4.3.0-0.rc2.git1.1.fc24.x86_64 fixes the issue for me...
Comment 12 Lukas Brabec 2015-10-09 05:08:57 EDT
Just updated from F22 to F23 on my T430s and I didn't encounter the bug.
Laptop is in docking station with external monitor and everything works as expected, but abrt caught https://bugzilla.redhat.com/show_bug.cgi?id=1254248.

Intel Core i7-3520M with:
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)


kernel-4.2.2-300.fc23.x86_64
xorg-x11-drv-intel-2.99.917-16.20150729.fc23.x86_64
Comment 13 Kamil Páral 2015-10-09 08:47:27 EDT
(In reply to Lukas Brabec from comment #12)
> kernel-4.2.2-300.fc23.x86_64
> xorg-x11-drv-intel-2.99.917-16.20150729.fc23.x86_64

In comment 5 I said I can't reproduce it with Broadwell, I was wrong, it just didn't happen always (but very often). With the latest kernel and intel driver as quoted, booting in docking station no longer seems to freeze the system, but I've seen:
a) intel driver sometimes crashes when docking the laptop (could not be reported with abrt because of tainted kernel), and gnome forgot my display configuration
b) after waking the displays up from standby mode (locked screen), very often my third display (second external display) does not wake up. I need to disable it and re-enable it in gnome configuration to wake it up.
c) sometimes display configuration (layout, rotation, primary display) is forgotten after monitor standby (locked screen)
Comment 14 Kamil Páral 2015-10-14 06:44:02 EDT
Even with kernel-4.2.3-300.fc23, I still see issues from comment 13. But the original issue from comment 0 seems to be fixed, it no longer freezes in docking station. Petr Schindler also confirms that. So I'm going to close this and we should report a new bugzilla ticket about the new issues.

Note You need to log in before you can comment on or make changes to this bug.