Bug 1256736 - hosted_engine agent doesn't launch after upgrade [NEEDINFO]
hosted_engine agent doesn't launch after upgrade
Status: CLOSED DUPLICATE of bug 1254745
Product: oVirt
Classification: Community
Component: ovirt-hosted-engine-ha (Show other bugs)
3.6
x86_64 Linux
unspecified Severity unspecified
: ---
: 3.6.0
Assigned To: Doron Fediuck
meital avital
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 07:11 EDT by Alexey Vyrodov
Modified: 2015-08-27 08:51 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-27 08:51:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dfediuck: needinfo? (vyrodov.alexey)


Attachments (Terms of Use)

  None (edit)
Description Alexey Vyrodov 2015-08-25 07:11:22 EDT
Description of problem:

Today i upgraded my test system for final version (i have july 21 version before).


Log below (/var/log/ovirt-hosted-engine-ha/):

MainThread::INFO::2015-08-25 13:55:27,094::hosted_engine::235::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(_get_hostname) Found certificate common name: imm10.virt
MainThread::INFO::2015-08-25 13:55:27,094::hosted_engine::577::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(_initialize_vdsm) Initializing VDSM
MainThread::INFO::2015-08-25 13:55:27,128::hosted_engine::620::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(_initialize_storage_images) Connecting the storage
MainThread::INFO::2015-08-25 13:55:27,129::storage_server::110::ovirt_hosted_engine_ha.lib.storage_server.StorageServer::(connect_storage_server) Connecting storage server
MainThread::ERROR::2015-08-25 13:55:27,129::agent::201::ovirt_hosted_engine_ha.agent.agent.Agent::(_run_agent) Error: ''StorageServer' object has no attribute 'storageType'' - trying to restart agent
MainThread::WARNING::2015-08-25 13:55:32,130::agent::204::ovirt_hosted_engine_ha.agent.agent.Agent::(_run_agent) Restarting agent, attempt '9'
MainThread::ERROR::2015-08-25 13:55:32,130::agent::206::ovirt_hosted_engine_ha.agent.agent.Agent::(_run_agent) Too many errors occurred, giving up. Please review the log and consider filing a bug.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Alexey Vyrodov 2015-08-25 08:52:08 EDT
rpm -q -a | grep ovirt
ovirt-vmconsole-1.0.0-0.0.master.20150821105434.gite14b2f0.el7.noarch
ovirt-release-master-001-0.10.master.noarch
ovirt-vmconsole-host-1.0.0-0.0.master.20150821105434.gite14b2f0.el7.noarch
ovirt-hosted-engine-ha-1.3.0-0.0.master.20150819082520.20150819082516.git183a4ff.el7.noarch
libgovirt-0.3.1-3.el7.x86_64
ovirt-engine-sdk-python-4.0.0.0-0.1.20150821.git8942fce.el7.centos.noarch
ovirt-host-deploy-1.4.0-0.0.master.20150806005708.git670e9c8.el7.noarch
ovirt-iso-uploader-4.0.0-0.0.master.20150819073358.git0fbcd20.el7.noarch
ovirt-setup-lib-1.0.0-0.0.master.20150812132738.git6a54bc0.el7.centos.noarch
ovirt-hosted-engine-setup-2.0.0-0.0.master.20150819153748.git90bec12.el7.centos.noarch
Comment 2 Doron Fediuck 2015-08-25 10:10:56 EDT
Did you upgrade hosts and the VM as well?
How did you upgrade?
Comment 3 Alexey Vyrodov 2015-08-26 07:22:13 EDT
Yes, hosts and the VM were upgraded.
yum update
Comment 4 Alexey Vyrodov 2015-08-26 16:05:20 EDT
After following sequence of commands two out off three node have worked corectly.

systemctl stop ovirt-ha-agent ovirt-ha-broker vdsmd
yum downgrade ovirt-hosted-engine-ha -y
yum upgrade ovirt-hosted-engine-ha -y
systemctl start ovirt-ha-agent ovirt-ha-broker
Comment 5 Doron Fediuck 2015-08-27 03:24:59 EDT
(In reply to Alexey Vyrodov from comment #4)
> After following sequence of commands two out off three node have worked
> corectly.
> 
> systemctl stop ovirt-ha-agent ovirt-ha-broker vdsmd
> yum downgrade ovirt-hosted-engine-ha -y
> yum upgrade ovirt-hosted-engine-ha -y
> systemctl start ovirt-ha-agent ovirt-ha-broker

Which maintenance mode was the host in during the upgrade?
Comment 6 Simone Tiraboschi 2015-08-27 08:51:02 EDT

*** This bug has been marked as a duplicate of bug 1254745 ***

Note You need to log in before you can comment on or make changes to this bug.