Bug 1254745 - ovirt 3.6 beta 2: ovirt-ha-agent crashes
ovirt 3.6 beta 2: ovirt-ha-agent crashes
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-hosted-engine-ha (Show other bugs)
3.6
x86_64 Linux
unspecified Severity high
: ---
: 3.6.0
Assigned To: Simone Tiraboschi
meital avital
integration
: Regression
: 1256631 1256736 1257395 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 14:38 EDT by wodel
Modified: 2015-08-27 11:22 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-27 11:22:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45061 master MERGED ha: removing wrong _self attribute access on gluster code Never
oVirt gerrit 45121 master MERGED removing wrong _self attribute access on gluster code Never

  None (edit)
Description wodel 2015-08-18 14:38:30 EDT
Description of problem:

ovirt-ha-agent crashes

Version-Release number of selected component (if applicable):

3.6 beta 2

How reproducible:

always

Steps to Reproduce:
1. Install ovirt-hosted-engine
2. At the end of the installation the service ovirt-ha-agent crashes after being started

Actual results:

ovirt-ha-agent crashes

Expected results:

ovirt-ha-agent start and starts the engine VM

Additional info:

Here is the error I get

MainThread::INFO::2015-08-18 19:31:14,588::hosted_engine::235::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(_get_hostname) Found certificate common name: noveria.wodel.wd
MainThread::INFO::2015-08-18 19:31:14,589::hosted_engine::577::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(_initialize_vdsm) Initializing VDSM
MainThread::INFO::2015-08-18 19:31:14,672::hosted_engine::620::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(_initialize_storage_images) Connecting the storage
MainThread::INFO::2015-08-18 19:31:14,673::storage_server::110::ovirt_hosted_engine_ha.lib.storage_server.StorageServer::(connect_storage_server) Connecting storage server
MainThread::ERROR::2015-08-18 19:31:14,673::agent::201::ovirt_hosted_engine_ha.agent.agent.Agent::(_run_agent) Error: ''StorageServer' object has no attribute '_self'' - trying to restart agent
MainThread::WARNING::2015-08-18 19:31:19,674::agent::204::ovirt_hosted_engine_ha.agent.agent.Agent::(_run_agent) Restarting agent, attempt '8'
MainThread::INFO::2015-08-18 19:31:19,685::hosted_engine::235::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(_get_hostname) Found certificate common name: noveria.wodel.wd
MainThread::INFO::2015-08-18 19:31:19,686::hosted_engine::577::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(_initialize_vdsm) Initializing VDSM
MainThread::INFO::2015-08-18 19:31:19,773::hosted_engine::620::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(_initialize_storage_images) Connecting the storage
MainThread::INFO::2015-08-18 19:31:19,774::storage_server::110::ovirt_hosted_engine_ha.lib.storage_server.StorageServer::(connect_storage_server) Connecting storage server
MainThread::ERROR::2015-08-18 19:31:19,775::agent::201::ovirt_hosted_engine_ha.agent.agent.Agent::(_run_agent) Error: ''StorageServer' object has no attribute '_self'' - trying to restart agent
MainThread::WARNING::2015-08-18 19:31:24,780::agent::204::ovirt_hosted_engine_ha.agent.agent.Agent::(_run_agent) Restarting agent, attempt '9'
MainThread::ERROR::2015-08-18 19:31:24,781::agent::206::ovirt_hosted_engine_ha.agent.agent.Agent::(_run_agent) Too many errors occurred, giving up. Please review the log and consider filing a bug.
MainThread::INFO::2015-08-18 19:31:24,781::agent::143::ovirt_hosted_engine_ha.agent.agent.Agent::(run) Agent shutting down


Regards
Comment 1 Simone Tiraboschi 2015-08-19 02:55:11 EDT
It glusterFS specific, it doesn't involves other storage types.
Comment 2 Simone Tiraboschi 2015-08-26 04:00:12 EDT
*** Bug 1256631 has been marked as a duplicate of this bug. ***
Comment 3 Simone Tiraboschi 2015-08-27 08:21:05 EDT
*** Bug 1257395 has been marked as a duplicate of this bug. ***
Comment 4 Simone Tiraboschi 2015-08-27 08:51:02 EDT
*** Bug 1256736 has been marked as a duplicate of this bug. ***
Comment 5 Alexey Vyrodov 2015-08-27 11:16:43 EDT
Today i update system. All have been worked fine.
Comment 6 Yaniv Lavi (Dary) 2015-08-27 11:22:30 EDT
Closing due to comment #5

Note You need to log in before you can comment on or make changes to this bug.