Bug 1256875 - Firefox crash on gmail login
Firefox crash on gmail login
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
22
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
: 1257297 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 11:54 EDT by Vitor Gomes
Modified: 2015-08-27 19:48 EDT (History)
5 users (show)

See Also:
Fixed In Version: 40.0.3-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-27 13:56:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash backtrace as per http://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products, as indicated by Stransky@redhat.com (223.30 KB, text/plain)
2015-08-25 11:54 EDT, Vitor Gomes
no flags Details

  None (edit)
Description Vitor Gomes 2015-08-25 11:54:20 EDT
Created attachment 1066920 [details]
Crash backtrace as per http://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products, as indicated by Stransky@redhat.com

Description of problem: Firefox crashes while trying to log in to gmail, when clicking "Next" after entering my e-mail adress.
Also happens when openning up a chat box on facebook, as in this bug 1255040 (https://bugzilla.redhat.com/show_bug.cgi?id=1255040)

Version-Release number of selected component (if applicable): firefox-40.0-4.fc22.x86_64


How reproducible:
Every time.

Steps to reproduce:
1. Load up https://mail.google.com on the browser;
2. Enter account email address;
3. Click "Next" button imediatelly below.

Actual results:
Component crashes before being able to enter password.

Additional info:
kernel: 4.1.5-200.fc22.x86_64
Comment 1 Vitor Gomes 2015-08-25 11:57:23 EDT
When crashed using dbg, firefox failed to produce a crash report.
Crash reproduced in equivalent conditions, report here:

https://crash-stats.mozilla.com/report/index/97d196fa-6101-4a35-af7f-ce4a32150825
Comment 2 Martin Stransky 2015-08-26 06:08:55 EDT
Yes, I see that, it's cased by broken (null) cairo context.
Comment 3 Martin Stransky 2015-08-26 06:24:05 EDT
Can you please:

- check you have OMTC disabled (in about:config layers.offmainthreadcomposition.enabled should be false)
- test latest nightly build from mozilla (https://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central/firefox-43.0a1.en-US.linux-x86_64.tar.bz2)
Comment 4 Martin Stransky 2015-08-26 06:31:47 EDT
Do you see that only on gmail or does it crash on other sites too?
Comment 5 Vitor Gomes 2015-08-26 07:29:51 EDT
OTMC is off, as default. Did test with it enabled, with the same results.

Haven't seen crashes anywhere other than on gmail and facebook, as described.
Will try the latest nightly on those two sites and report back.
Comment 6 Vitor Gomes 2015-08-26 07:54:16 EDT
Nightly build seems to work good, no crashes in either situations.
Comment 7 Martin Stransky 2015-08-26 08:03:34 EDT
Looks like you hit https://bugzilla.mozilla.org/show_bug.cgi?id=1127752 - which is fixed in Firefox 41. I'll try to include the patch in our next update.
Comment 8 Martin Stransky 2015-08-26 08:25:02 EDT
Added the upstream patch to firefox-40.0-10 - will be available here:
http://koji.fedoraproject.org/koji/packageinfo?packageID=37
Comment 9 Vitor Gomes 2015-08-26 12:07:57 EDT
Started to see crashes in some other sites, navigating ebay.co.uk for example. 
Should be related to the same bug, again Nightly build works good.
Comment 10 Olivier Crête 2015-08-26 14:59:30 EDT
*** Bug 1257297 has been marked as a duplicate of this bug. ***
Comment 11 Martin Stransky 2015-08-26 15:49:56 EDT
Can you please test those builds? http://koji.fedoraproject.org/koji/buildinfo?buildID=680314
Comment 12 Vitor Gomes 2015-08-27 07:08:30 EDT
As with the nightly build, no crashes in any of the previous places.
One caveat though: on facebook, the right hand column seems to be missing the facebook chat friend list (http://goo.gl/PAMJrA, p.ex), and on fB chat tabs some (not all, strangely) user profile photos are "broken", the "torn document" icon appears instead.

These I can live with though. Thanks for the help!
Comment 13 Vitor Gomes 2015-08-27 07:10:18 EDT
Forgot to mention, that's with the 40.0-10 build.
Comment 14 Fedora Update System 2015-08-27 09:19:01 EDT
firefox-40.0.3-1.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14411
Comment 15 Fedora Update System 2015-08-27 09:19:13 EDT
firefox-40.0.3-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14412
Comment 16 Fedora Update System 2015-08-27 09:19:23 EDT
firefox-40.0.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14413
Comment 17 Fedora Update System 2015-08-27 13:56:53 EDT
firefox-40.0.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2015-08-27 14:22:20 EDT
firefox-40.0.3-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2015-08-27 19:48:41 EDT
firefox-40.0.3-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.