Bug 1257297 - Reproducible crash on plus.google.com in Cairo
Reproducible crash on plus.google.com in Cairo
Status: CLOSED DUPLICATE of bug 1256875
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 13:37 EDT by Olivier Crête
Modified: 2015-08-26 14:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-26 14:59:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier Crête 2015-08-26 13:37:17 EDT
Description of problem:

Reproducible crash in cairo, did not happen in previous version

Version-Release number of selected component (if applicable):

firefox-40.0-4.fc22.x86_64

Program received signal SIGSEGV, Segmentation fault.
INT_cairo_new_path (cr=0x0) at cairo.c:1437
1437	    if (unlikely (cr->status))
(gdb) bt
#0  0x00007fb0a0fd2630 in INT_cairo_new_path (cr=0x0) at cairo.c:1437
#1  0x00007fb096eebd3e in moz_gtk_widget_paint ()
    at /usr/lib64/firefox/libxul.so
#2  0x00007fb096f11227 in nsNativeThemeGTK::DrawWidgetBackground(nsRenderingContext*, nsIFrame*, unsigned char, nsRect const&, nsRect const&) ()
    at /usr/lib64/firefox/libxul.so
#3  0x00007fb0970435a0 in nsDisplayThemedBackground::PaintInternal(nsDisplayListBuilder*, nsRenderingContext*, nsRect const&, nsRect*) ()
    at /usr/lib64/firefox/libxul.so
#4  0x00007fb097024f33 in mozilla::FrameLayerBuilder::PaintItems(nsTArray<mozilla::FrameLayerBuilder::ClippedDisplayItem>&, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const&, gfxContext*, nsRenderingContext*, nsDisplayListBuilder*, nsPresContext*, mozilla::gfx::IntPointTyped<mozilla::gfx::UnknownUnits> const&, float, float, int) () at /usr/lib64/firefox/libxul.so
#5  0x00007fb097029117 in mozilla::FrameLayerBuilder::DrawPaintedLayer(mozilla::layers::PaintedLayer*, gfxContext*, nsIntRegion const&, mozilla::layers::DrawRegionClip, nsIntRegion const&, void*) () at /usr/lib64/firefox/libxul.so
#6  0x00007fb0963e2885 in mozilla::layers::ClientPaintedLayer::PaintThebes() ()
    at /usr/lib64/firefox/libxul.so
#7  0x00007fb0963e5bf5 in mozilla::layers::ClientPaintedLayer::RenderLayerWithReadback(mozilla::layers::ReadbackProcessor*) () at /usr/lib64/firefox/libxul.so
#8  0x00007fb0963d9cf3 in mozilla::layers::ClientContainerLayer::RenderLayer() () at /usr/lib64/firefox/libxul.so
---Type <return> to continue, or q <return> to quit---
#9  0x00007fb0963d9cf3 in mozilla::layers::ClientContainerLayer::RenderLayer() () at /usr/lib64/firefox/libxul.so
#10 0x00007fb0963d63b4 in mozilla::layers::ClientLayerManager::EndTransactionInternal(void (*)(mozilla::layers::PaintedLayer*, gfxContext*, nsIntRegion const&, mozilla::layers::DrawRegionClip, nsIntRegion const&, void*), void*, mozilla::layers::LayerManager::EndTransactionFlags) () at /usr/lib64/firefox/libxul.so
#11 0x00007fb0963ddf18 in mozilla::layers::ClientLayerManager::EndTransaction(void (*)(mozilla::layers::PaintedLayer*, gfxContext*, nsIntRegion const&, mozilla::layers::DrawRegionClip, nsIntRegion const&, void*), void*, mozilla::layers::LayerManager::EndTransactionFlags) () at /usr/lib64/firefox/libxul.so
#12 0x00007fb09704f8f6 in nsDisplayList::PaintRoot(nsDisplayListBuilder*, nsRenderingContext*, unsigned int) () at /usr/lib64/firefox/libxul.so
#13 0x00007fb09708b3ad in nsLayoutUtils::PaintFrame(nsRenderingContext*, nsIFrame*, nsRegion const&, unsigned int, unsigned int) ()
    at /usr/lib64/firefox/libxul.so
#14 0x00007fb09708bcac in PresShell::Paint(nsView*, nsRegion const&, unsigned int) () at /usr/lib64/firefox/libxul.so
#15 0x00007fb096ecd400 in nsViewManager::ProcessPendingUpdatesPaint(nsIWidget*) () at /usr/lib64/firefox/libxul.so
#16 0x00007fb096ecd65d in nsViewManager::ProcessPendingUpdatesForView(nsView*, bool) () at /usr/lib64/firefox/libxul.so
#17 0x00007fb097010a6d in nsRefreshDriver::Tick(long, mozilla::TimeStamp) ()
    at /usr/lib64/firefox/libxul.so
---Type <return> to continue, or q <return> to quit---
#18 0x00007fb097010fc7 in mozilla::RefreshDriverTimer::Tick(long, mozilla::TimeStamp) () at /usr/lib64/firefox/libxul.so
#19 0x00007fb0970110ee in mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::TickRefreshDriver(mozilla::TimeStamp) ()
    at /usr/lib64/firefox/libxul.so
#20 0x00007fb09700dfc8 in nsRunnableMethodImpl<void (mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::*)(mozilla::TimeStamp), true, mozilla::TimeStamp>::Run() () at /usr/lib64/firefox/libxul.so
#21 0x00007fb095e87ff6 in nsThread::ProcessNextEvent(bool, bool*) ()
    at /usr/lib64/firefox/libxul.so
#22 0x00007fb095e9c4cd in NS_ProcessNextEvent(nsIThread*, bool) ()
    at /usr/lib64/firefox/libxul.so
#23 0x00007fb09605c883 in mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) () at /usr/lib64/firefox/libxul.so
#24 0x00007fb09604c88c in MessageLoop::Run() () at /usr/lib64/firefox/libxul.so
#25 0x00007fb096edb589 in nsBaseAppShell::Run() ()
    at /usr/lib64/firefox/libxul.so
#26 0x00007fb097412671 in nsAppStartup::Run() ()
    at /usr/lib64/firefox/libxul.so
#27 0x00007fb09744709c in XREMain::XRE_mainRun() ()
    at /usr/lib64/firefox/libxul.so
#28 0x00007fb097447381 in XREMain::XRE_main(int, char**, nsXREAppData const*) () at /usr/lib64/firefox/libxul.so
---Type <return> to continue, or q <return> to quit---
#29 0x00007fb0974475e6 in XRE_main () at /usr/lib64/firefox/libxul.so
#30 0x00000000004042f7 in do_main(int, char**, nsIFile*) [clone .constprop.0] ()
#31 0x0000000000403a74 in main ()
Comment 1 Olivier Crête 2015-08-26 14:25:46 EDT
Also happens on 40.0-7
Comment 2 Olivier Crête 2015-08-26 14:59:30 EDT
It's fixed in 40.0-10, so I assume it'S a duplicate of #1256875

*** This bug has been marked as a duplicate of bug 1256875 ***

Note You need to log in before you can comment on or make changes to this bug.