Bug 1256944 - SmartState Analysis on EC2 instance via Quadicon
SmartState Analysis on EC2 instance via Quadicon
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity low
: GA
: 5.4.5
Assigned To: lgalis
Satyajit Bulage
ec2:ui:vm:smartstate
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 15:55 EDT by Sean Myers
Modified: 2016-10-26 11:57 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.4.5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-29 10:14:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SmartState Analysis available for EC2 instances (86.93 KB, image/png)
2015-08-25 15:55 EDT, Sean Myers
no flags Details

  None (edit)
Description Sean Myers 2015-08-25 15:55:04 EDT
Created attachment 1066976 [details]
SmartState Analysis available for EC2 instances

Description of problem:
As seen in https://bugzilla.redhat.com/show_bug.cgi?id=1245717#c16, the UI indicates that SmartState Analysis (SSA) of ec2 instances is possible when selecting an instance's quadicon in a list view, and reports that it has started SSA on a chosen ec2 instance when that option is used.

Version-Release number of selected component (if applicable):
5.4.2.0

Steps to Reproduce:
1. Add an EC2 provider with instances
2. Navigate to that provider's instance list (Clouds > Instance > (ec2 provider in accordion)
3. Check the box for an instance's quadicon
4. In the toolbar: Configuration > Perform SmartState Analysis

Actual results:
CFME Appears to start SSA on the EC2 instance

Expected results:
The "Perform SmartState Analysis" toolbar option should not be present, or (since this view is shared with providers that do support SSA) the user should see an error/warning message of some sort when attempting SSA if an EC2 instance is among the selected instances.

Additional info:
Screenshot attached showing the errant menu item.
Comment 5 Vadim Rutkovsky 2016-02-11 13:41:44 EST
Still occurs in 5.4.z (5.4.5.0.20160120124945_d8bf7e3) - no error message appears, SSA task starts up and seems to hang in 'waiting_to_start' state


Cannot reproduce in latest 5.5.2.4 - correct error message appears
Comment 8 CFME Bot 2016-02-24 16:54:13 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=cf2100647ecd10f57dc3daef2018aacdf311b2f7

commit cf2100647ecd10f57dc3daef2018aacdf311b2f7
Author:     Laura Galis <lgalis@redhat.com>
AuthorDate: Tue Feb 23 11:37:44 2016 -0500
Commit:     Laura Galis <lgalis@redhat.com>
CommitDate: Wed Feb 24 08:39:18 2016 -0500

     SmartState Analysis on EC2 instance via Quadicon
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1256944
    
    Display Message when one of the selected instances does not support SSA

 .../application_controller/ci_processing.rb        |  4 ++++
 vmdb/app/models/vm_cloud.rb                        |  2 +-
 vmdb/app/models/vm_openstack.rb                    |  2 +-
 vmdb/app/models/vm_or_template.rb                  |  9 +++++++++
 vmdb/app/models/vm_or_template/scanning.rb         |  8 ++++++++
 vmdb/app/models/vm_redhat.rb                       |  2 +-
 vmdb/app/models/vm_vmware.rb                       |  2 +-
 .../application_controller/ci_processing_spec.rb   | 23 ++++++++++++++++++++++
 vmdb/spec/helpers/application_helper_spec.rb       |  2 ++
 vmdb/spec/models/vm_or_template_spec.rb            |  2 ++
 10 files changed, 52 insertions(+), 4 deletions(-)
Comment 9 CFME Bot 2016-02-24 16:54:17 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=55bb6dded365bbc7867394dd245aeae86de7a71d

commit 55bb6dded365bbc7867394dd245aeae86de7a71d
Merge: c4cc2d20 cf21006
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Wed Feb 24 11:50:58 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Wed Feb 24 11:50:58 2016 -0500

    Merge branch '5.4.z_smartstate_validate_button' into '5.4.z'
    
    5.4.z smartstate validate button
    
    SmartState Analysis on EC2 instance via Quadicon
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1256944
    
    Manual merge for:
    https://github.com/ManageIQ/manageiq/pull/5378
    https://github.com/ManageIQ/manageiq/pull/5210
    
    
    
    
    
    See merge request !812

 .../application_controller/ci_processing.rb        |  4 ++++
 vmdb/app/models/vm_cloud.rb                        |  2 +-
 vmdb/app/models/vm_openstack.rb                    |  2 +-
 vmdb/app/models/vm_or_template.rb                  |  9 +++++++++
 vmdb/app/models/vm_or_template/scanning.rb         |  8 ++++++++
 vmdb/app/models/vm_redhat.rb                       |  2 +-
 vmdb/app/models/vm_vmware.rb                       |  2 +-
 .../application_controller/ci_processing_spec.rb   | 23 ++++++++++++++++++++++
 vmdb/spec/helpers/application_helper_spec.rb       |  2 ++
 vmdb/spec/models/vm_or_template_spec.rb            |  2 ++
 10 files changed, 52 insertions(+), 4 deletions(-)
Comment 11 Vadim Rutkovsky 2016-03-21 06:29:16 EDT
Verified on 5.4.5.2.20160315175001_800759c
Comment 13 errata-xmlrpc 2016-03-29 10:14:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0171.html

Note You need to log in before you can comment on or make changes to this bug.