Bug 1256960 - unexpected "Registering to: hostname:port/prefix" when calling subscription-manager service-level
unexpected "Registering to: hostname:port/prefix" when calling subscription-m...
Status: CLOSED DUPLICATE of bug 1254349
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: vritant
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 17:38 EDT by John Sefler
Modified: 2015-08-27 14:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-27 14:17:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2015-08-25 17:38:54 EDT
Description of problem:
As a side affect of https://bugzilla.redhat.com/show_bug.cgi?id=985157#c13 we now get an additional stdout message when executing subscription-manager service-level module stating ...
Registering to: hostname:port/prefix

Version-Release number of selected component (if applicable):
[root@jsefler-7 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.6-1
subscription management rules: 5.16
subscription-manager: 1.15.9-6.el7
python-rhsm: 1.15.4-2.el7


How reproducible:


Steps to Reproduce:
[root@jsefler-7 ~]# subscription-manager service-level --list --username=testuser1 --password=REDACTED --org=admin --insecure --serverurl=jsefler-f22-candlepin.usersys.redhat.com:8443/candlepin
Registering to: jsefler-f22-candlepin.usersys.redhat.com:8443/candlepin
+-------------------------------------------+
               Available Service Levels
+-------------------------------------------+
Full-Service
Generic SLA
None
Premium
Standard
Super



Actual results:
above

Expected results:
  the stdout from calls to the service-level module should exclude the "Registering to:" message

Additional info:
Comment 1 vritant 2015-08-27 14:17:55 EDT
Root cause is same as https://bugzilla.redhat.com/show_bug.cgi?id=1254349 , so marking this as duplicate

*** This bug has been marked as a duplicate of bug 1254349 ***

Note You need to log in before you can comment on or make changes to this bug.