Bug 12570 - Headless installatoin problem with 6.2 SBE 2
Headless installatoin problem with 6.2 SBE 2
Product: Red Hat Linux
Classification: Retired
Component: pxe (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Erik Troan
: 12530 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2000-06-19 12:30 EDT by chun ming li
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-07-06 12:17:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description chun ming li 2000-06-19 12:30:05 EDT
After configuring DHCP and PXE server on one system.  
The client boots up, got IP from dhcp server and
start remote installation of Linux.
It found the boot server, then it prompt 
"Press any key to enter kernel parameters.."
If you let it default, it would down loaded the kernel image
and initrd image.

"Downloading Linux kernel image...
  Downloading initrd image...
 Uncompressing Linux... Ok, booting the kernel."

It hangs when it try to boot the kernel.

If you do enter the kernel parameter by typing in "ks" 
It would boot the kernel and locate the kickstart file to complete the 
headless installation.
Comment 1 Ken Crandall 2000-06-19 13:35:37 EDT
 We grabbed from rawhide and that does not fix the problem.  

 This is preventing us from getting a working version of RHL to our WW 
 sales force and customers.  We need a binary conatining this fix, verified 
 by RH, posted on a RH support site with instructions on how to apply the 
 fix to RHL 6.2.

 Problem Details below:

 -----Original Message-----
 From: Erik Troan [mailto:ewt@redhat.com]
 Sent: Thursday, June 15, 2000 4:07 PM
 To: 'kickstart-list@redhat.com'
 Subject: RE: kickstart - bootnet.img kernel hang

 Sounds like a bug in the loader -- I suggest grabbing the pxelinux boot
 loader from rawhide and trying it (the Intel PXE kernel loader has known


 On Thu, 15 Jun 2000, Krig, Steve B wrote:

 > "Downloading Linux kernel image...
 >  Downloading initrd image...
 >  Uncompressing Linux... Ok, booting the kernel."
 > Hangs here.  No more console output.
 > -----Original Message-----
 > From: Erik Troan [mailto:ewt@redhat.com]
 > Sent: Thursday, June 15, 2000 12:28 PM
 > To: 'kickstart-list@redhat.com'
 > Subject: Re: kickstart - bootnet.img kernel hang
 > What's hang mean? If the kernel starting up at all?
 > Erik
 > On Thu, 15 Jun 2000, Krig, Steve B wrote:
 > > 
 > > with RHL 6.2, we are not able to use kickstart for unattended installs
 > > the kernel is hanging.
 > > 
 > > We are seeing the bootnet kernel hang after it is loaded/uncompressed
 > > PXE.   
 > > 
 > >   > mount -o loop -t vfat /redhat-cdrom/images/bootnet.img /mnt/floppy
 > >   > cp /mnt/floppy/vmlinuz /tftpboot/X86PC/UNDI/linux-install/linux.1
 > >   > cp /mnt/floppy/initrd.img /tftpboot/X86PC/UNDI/linux-
 > > 
 > > Can we get a kernel image fix?
 > > 
 > > thanks
 > > -steve
 > > 
 > >
Comment 2 Preston Brown 2000-06-20 16:57:59 EDT
did you try entering "linux console=ttyS0" as boot parameters?
Comment 3 chun ming li 2000-06-29 11:45:57 EDT
If I understand it correctly, Redhat suggeted trying to:

send the client machine pxelinux.bin, not the kernel image

My assumption is that they're suggesting to replace /tftpboot/X86PC/UNDI/linux-
with PXELINUX.BIN from the SYSLINUX package.  Tried this.  With the Chardonnay, 
it attemps to grab PXELINUX.BIN and execute it but the system hangs.  

Thinking that PXELINUX.BIN might be the bootloader replacement, I also tried 
replacing the file /tftpboot/X86PC/UNDI/linux-install/linux.0 with PXELINUX.BIN 
and the Chardonnay hangs

Using a "NetPC" client which contains the "LANDesk Service Agent v0.99j" boot 
agent, I'm able to connect to the PXE server.  By replacing the bstrap.0 file 
with pxelinxu.bin the client was able grab PXELINUX.BIN and execute it.  

So it appears that PXELINUX.BIN does not work with the Chardonney clients 
(which PXE-2.0)
Tried a client with addin PRO100+ NIC (contains PXE-1.0) with same unsucessful 

Also I tried to send the pxelinux.bin image over to the client through a TFTP 
This method works with the netpc client but don't work with Chardonnay.
Comment 4 Matt Wilson 2000-06-30 16:04:02 EDT
There are major problems with the bootloader that comes in the pxe package. 
When using initrd in several memory configurations, data is overwritten before
the kernel boots.  This causes lockups and unusual behavior after booting the

We use the pxelinux bootloader for network booting here.  You need the tftp
server and pxe server from rawhide in order to make it work.  I can provide
packages built for a 6.2 system if needed.

pxelinux is not a drop-in replacement for the loader that comes with the Intel
pxe server.  Read the pxelinux documentation for details.
Comment 5 Matt Wilson 2000-07-03 16:45:41 EDT
*** Bug 12530 has been marked as a duplicate of this bug. ***
Comment 6 Matt Wilson 2000-07-05 14:13:32 EDT
The test box we have here plugged into our test OS environment and pxe booted
into the installer on the first try.
Comment 7 Matt Wilson 2000-07-05 14:28:28 EDT
A few things that are hard to relay on the phone:

Using the 6.2 pxe server, pxelinux will not get the "myip" part of the
dhcp reply packet.  This means that pxelinux will say, "My IP address
seems to be".  It will then try to load its configuration file
via tftp by loading:


This is fine if you want to use the same pxelinux configuration for
ever machine, you just make one configuration file named 00000000.
Only if you want per-IP configuration files do you need a modified pxe

Be sure to configure the pxe server properly:


# Menu string that will be displayed on the client screen
# after F8 is pressed.
10,Linux Install
0,Local Boot


# Image file name for BStrap boot server
# format : <min layer #> <max layer #> <base file name>


In /tftpboot/X86PC/UNDI/pxelinux/ you should have:
pxelinux.0 <-- pxelinux binary file
pxelinux.cfg/ <-- directory for config files
pxelinux.cfg/00000000 <-- default configuration file

In our configuration, we also have the following in our pxelinux/


These are the images that I use for my install testing.  In our
configuration there is one directory per developer.

Our default pxelinux configuration (pxelinux.cfg/default) looks like

default linux
prompt 1
timeout 50
label linux
  kernel msw/vmlinuz
  append initrd=msw/initrd.img ks

Now, the last piece is the in.tftpd server.  I've placed a RPM of the
server we use on our pxe server at:


You must modify the /etc/inetd.conf to read:
tftp    dgram   udp     wait    root    /usr/sbin/tcpd  in.tftpd -s /tftpboot

(default 6.2 reads:)
tftp   dgram   udp     wait    root    /usr/sbin/tcpd  in.tftpd

This gives you a side effect of having a secure chroot() tftp serving
space, good for the security conscious administrator.

I double checked our mtftp configuration and it seems that we don't
use mtftp to serve the pxelinux.0.  Sorry for sending you down the
wrong path on that one.
Comment 8 chun ming li 2000-07-06 12:17:13 EDT
With a few modification to the configuration notes above, we were able to 
implement pxelinux with Redhat 6.2 SBE2 to do a complete headless installation.

Configuration notes:

The stock 6.2 tftpd does not work with pxelinux.
We need to down load the tftp-hpa-0.13.tar.gz from 

Set the prompt and timeout to 0 in the default pxelinux configuration file.  
Our default configuration file look like this:

default linux
prompt 0
timeout 0
label linux
  kernel vmlinuz
  append initrd=msw/initrd.img ks

Comment 9 chun ming li 2000-07-12 14:35:34 EDT
With additional modifications to the pxe.conf and /etc/services.
We were able to use pxe to do a full headless and handfree installation of 
Redhat 6.2 SBE 2.

We have completed headless installation using PXE and PXElinuxl.

Note You need to log in before you can comment on or make changes to this bug.