Bug 1257051 - cups-lpd man page incomplete
cups-lpd man page incomplete
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cups (Show other bugs)
7.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Zdenek Dohnal
Petr Sklenar
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 03:28 EDT by Todd
Modified: 2016-11-04 02:45 EDT (History)
4 users (show)

See Also:
Fixed In Version: cups-1.6.3-24.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:45:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
updated cups-lpd-manpage.patch (2.60 KB, patch)
2015-10-29 08:40 EDT, Jiri Popelka
no flags Details | Diff

  None (edit)
Description Todd 2015-08-26 03:28:34 EDT
Hi All,

I am coming from the community: Scientific Linux 7.1.

# yum whatprovides cups-lpd
Loaded plugins: langpacks
1:cups-lpd-1.6.3-17.el7.x86_64 : CUPS printing system - lpd emulation
Repo        : sl


Bug #1:

# rpm -qa cups-lpd
cups-lpd-1.6.3-17.el7_1.1.x86_64

is missing the dependency: 

# rpm -qa xinetd
xinetd-2.3.15-12.el7.x86_64

You can't use cups-lpd without it.



Bug #2:
the installer of cups-lpd forgets to add the following entry into /etc/xinetd.d

$ more cups-lpd

# default: off
# description: Allow applications using the legacy lpd protocol to communicate w
ith CUPS
service printer
{
	disable = no
	socket_type = stream
	protocol = tcp
	wait = no
	user = lp
	server = /usr/lib/cups/daemon/cups-lpd
}


Many thanks,
-T
Comment 3 Jiri Popelka 2015-08-26 05:57:28 EDT
We converted cups-lpd xinetd service to systemd, see bug #884641 for more details.
Comment 4 Todd 2015-08-26 18:42:42 EDT
Hi Jiri,

Would you consider adding these two command to the post install script?

# systemctl enable cups-lpd.socket
# systemctl start cups-lpd.socket

Many thanks,
-T
Comment 5 Jiri Popelka 2015-08-27 04:10:12 EDT
No, sorry.
We'd need an exception for this and I'm not sure we really need it.

https://fedoraproject.org/wiki/Packaging:DefaultServices
Comment 6 Todd 2015-08-27 05:07:29 EDT
(In reply to Jiri Popelka from comment #5)
> No, sorry.
> We'd need an exception for this and I'm not sure we really need it.
> 
> https://fedoraproject.org/wiki/Packaging:DefaultServices


In that case, how about putting something in the cup-lpd man page so folks won't have to rely on the charity of others to figure out how to start the buzzard?
Comment 7 Jiri Popelka 2015-10-29 08:40 EDT
Created attachment 1087468 [details]
updated cups-lpd-manpage.patch
Comment 8 Tim Waugh 2015-11-02 04:48:24 EST
Man page patch looks great.
Comment 15 errata-xmlrpc 2016-11-04 02:45:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2459.html

Note You need to log in before you can comment on or make changes to this bug.