Bug 1257103 - test case 033 099 of qemu-iotests failed for vhdx
Summary: test case 033 099 of qemu-iotests failed for vhdx
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jeff Cody
QA Contact: Ping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-26 09:51 UTC by mazhang
Modified: 2016-11-07 20:36 UTC (History)
9 users (show)

Fixed In Version: qemu 2.6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 20:36:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
qemu-iotests result (3.16 KB, text/plain)
2015-08-26 09:51 UTC, mazhang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description mazhang 2015-08-26 09:51:27 UTC
Created attachment 1067212 [details]
qemu-iotests result

Description of problem:
test case 033 099 of qemu-iotests failed for vhdx

Version-Release number of selected component (if applicable):

Host:
qemu-kvm-rhev-2.3.0-19.el7.x86_64

How reproducible:
1/1

Steps to Reproduce:
1.Download qemu-kvm-rhev-2.3.0-19.el7.src.rpm, test vmdk.

#rpm2cpio qemu-kvm-rhev-2.3.0-19.el7.src.rpm|cpio -iv
#bzip2 -d qemu-2.3.0.tar.bz2 
#tar xvf qemu-2.3.0.tar 
#cd qemu-2.3.0/tests/qemu-iotests/
#export QEMU_PROG=/usr/libexec/qemu-kvm
#./check -vhdx


Actual results:
Attached

Expected results:


Additional info:

Comment 3 Mike McCune 2016-03-28 22:44:25 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 5 Ping Li 2016-08-10 13:56:11 UTC
Verify the issue with qemu-kvm-rhev-2.6.0-19.el7. After test with below steps, case 033 passed and case 099 has been removed from qemu-iotests. Case 118 and 120 failed due to Bug 1331279.

Test steps:
#git clone git://git.app.eng.bos.redhat.com/virt/rhel7/qemu-kvm.git
#cd qemu-kvm
#git checkout qemu-kvm-rhev-2.6.0-19.el7
#yum install zlib* glib* -y
#git submodule update --init pixman dtc
#cd tests/qemu-iotests
#export QEMU_PROG=/usr/libexec/qemu-kvm
#./check -vhdx

Comment 8 errata-xmlrpc 2016-11-07 20:36:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.