Bug 1257132 - removing VM pool job doesn't end
removing VM pool job doesn't end
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-3.6.0-ga
: 3.6.0
Assigned To: Shmuel Melamud
sefi litmanovich
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 06:39 EDT by Oved Ourfali
Modified: 2016-02-10 14:24 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 06:29:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
rule-engine: blocker+
ylavi: planning_ack+
michal.skrivanek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46473 master MERGED core: Correctly finish Remove VM Pool job Never
oVirt gerrit 47077 ovirt-engine-3.6 MERGED core: Correctly finish Remove VM Pool job Never
oVirt gerrit 47126 ovirt-engine-3.6.0 MERGED core: Correctly finish Remove VM Pool job Never

  None (edit)
Description Oved Ourfali 2015-08-26 06:39:22 EDT
Description of problem:
When removing a VM pool of VMs (with disks), the removal works, but the task never ends.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create VM pool from template, with at least 2 VMs, and the template should consist of at least one disk
2. Remove the VM pool


Actual results:
The tasks never end.

Expected results:
They should end.

Additional info:

1:

The issue is that as of 3.6, RemoveVmPoolCommand calls RemoveVmCommand.
RemoveVmCommand sets the parent command to the RemoveVmPoolCommand, and not to the RemoveVmCommand.

Not sure what's the right thing to do there. Either to set the parent to the current command, or to implement endAction logic in the RemoveVmPoolCommand.
The patch that changed RemoveVmCommand in the past was "git show 5633d52a".

Changing it back fixed the issue, but not sure whether it screwed up something else.

2:
I'm aware of the following bugs:
Bug 1211512 - POOL vm tasks doesn't ends 
Bug 1248090 - Tasks drawer doesn't display jobs/step tree correctly

However, the issue happens regardless, and it shouldn't interfere with reproducing + fixing this issue. The tree will still be "weird", but we have a patch for that that is under verification (https://gerrit.ovirt.org/#/c/45008/).
Comment 1 sefi litmanovich 2015-10-25 08:03:19 EDT
Verified with rhevm-3.6.0.2-0.1.el6.noarch according to steps in description.
Comment 2 Sandro Bonazzola 2015-11-04 06:29:02 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.