Bug 1257149 - Provide more meaningful errors on peer probe and peer detach
Provide more meaningful errors on peer probe and peer detach
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Brad Hubbard
:
Depends On:
Blocks: 1257394
  Show dependency treegraph
 
Reported: 2015-08-26 07:20 EDT by Brad Hubbard
Modified: 2016-06-16 09:33 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1257394 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:33:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Hubbard 2015-08-26 07:20:33 EDT
Description of problem:

When a peer probe or peer detach fails glusterd currently reports "peer probe: failed: Probe returned with unknown errno 107". The process should be able to provide more information than that.
Comment 1 Brad Hubbard 2015-08-26 22:03:17 EDT
http://review.gluster.org/#/c/12021/
Comment 2 Anand Avati 2015-08-26 22:16:17 EDT
REVIEW: http://review.gluster.org/12021 (glusterd: Return better error messages for probe and detach failures) posted (#2) for review on master by Brad Hubbard (bhubbard@redhat.com)
Comment 3 Anand Avati 2015-08-30 21:25:29 EDT
REVIEW: http://review.gluster.org/12021 (glusterd: Return better error messages for probe and detach failures) posted (#3) for review on master by Brad Hubbard (bhubbard@redhat.com)
Comment 4 Anand Avati 2015-08-30 21:25:38 EDT
REVIEW: http://review.gluster.org/12049 (fix testcase that depends on peer probe error output) posted (#1) for review on master by Brad Hubbard (bhubbard@redhat.com)
Comment 5 Anand Avati 2015-08-31 04:49:23 EDT
REVIEW: http://review.gluster.org/12021 (glusterd: Return better error messages for probe and detach failures) posted (#4) for review on master by Brad Hubbard (bhubbard@redhat.com)
Comment 6 Niels de Vos 2016-06-16 09:33:45 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.