This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1257394 - Provide more meaningful errors on peer probe and peer detach
Provide more meaningful errors on peer probe and peer detach
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.7.5
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Brad Hubbard
Byreddy
:
Depends On: 1257149
Blocks: 1260530
  Show dependency treegraph
 
Reported: 2015-08-26 22:13 EDT by Brad Hubbard
Modified: 2015-10-14 06:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1257149
: 1260530 (view as bug list)
Environment:
Last Closed: 2015-10-14 06:29:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Hubbard 2015-08-26 22:13:06 EDT
+++ This bug was initially created as a clone of Bug #1257149 +++

Description of problem:

When a peer probe or peer detach fails glusterd currently reports "peer probe: failed: Probe returned with unknown errno 107". The process should be able to provide more information than that.

--- Additional comment from Brad Hubbard on 2015-08-26 22:03:17 EDT ---

http://review.gluster.org/#/c/12021/
Comment 1 Brad Hubbard 2015-09-07 01:48:26 EDT
http://review.gluster.org/#/c/12111/
Comment 2 Vijay Bellur 2015-09-07 03:51:25 EDT
REVIEW: http://review.gluster.org/12111 (glusterd: Return better error messages for probe and detach failures) posted (#2) for review on release-3.7 by Brad Hubbard (bhubbard@redhat.com)
Comment 3 Vijay Bellur 2015-09-08 04:57:07 EDT
COMMIT: http://review.gluster.org/12111 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit 4932409c92928ae1a6a2a158c4cd311b0c75973c
Author: Brad Hubbard <bhubbard@redhat.com>
Date:   Wed Aug 19 18:56:06 2015 +1000

    glusterd: Return better error messages for probe and detach failures
    
    We handle some specific errors and return good error messages for those, but for
    the default case where the error code is not recognised we just report "unknown
    errno". This patch attempts to at least return the output of strerror to provide
    more informative errors.
    
    Cherry picked from commit 4b5aec8da9be69da077e1fcc7e852d224517ecc0:
    >BUG: 1257149
    >Change-Id: I0027e74e41adac4ab0c0a929c6fff56878bf39c8
    >Signed-off-by: Brad Hubbard <bhubbard@redhat.com>
    >Reviewed-on: http://review.gluster.org/12021
    >Reviewed-by: Niels de Vos <ndevos@redhat.com>
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    BUG: 1257394
    Change-Id: I11e6c006c6b93a5c1b915f8c509f24123497301d
    Signed-off-by: Brad Hubbard <bhubbard@redhat.com>
    Reviewed-on: http://review.gluster.org/12111
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 4 Pranith Kumar K 2015-10-14 06:29:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 5 Pranith Kumar K 2015-10-14 06:38:31 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.