Bug 1257270 - Fix logging version in neutron logs coming from pbr
Fix logging version in neutron logs coming from pbr
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity unspecified
: z2
: 7.0 (Kilo)
Assigned To: Jakub Libosvar
Alexander Stafeyev
: Triaged, ZStream
Depends On:
Blocks: 1257271
  Show dependency treegraph
 
Reported: 2015-08-26 11:28 EDT by Jakub Libosvar
Modified: 2016-04-26 20:18 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-neutron-2015.1.0-17.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1257271 (view as bug list)
Environment:
Last Closed: 2015-10-08 08:07:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 244145 None None None Never

  None (edit)
Description Jakub Libosvar 2015-08-26 11:28:46 EDT
Description of problem:
Currently we log only version without a release:
/usr/bin/neutron-server version 2015.1.0

and we log nothing in previous versions.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Alexander Stafeyev 2015-09-10 05:10:40 EDT
[root@puma09 ~]# rpm -qa |grep neutr
openstack-neutron-2015.1.1-2.el7ost.noarch


[root@puma09 ~]# grep version /var/log/neutron/server.log
2015-09-10 10:32:55.400 26116 INFO neutron.common.config [-] /usr/bin/neutron-server version 2015.1.1-2.el7ost
Comment 5 errata-xmlrpc 2015-10-08 08:07:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1866

Note You need to log in before you can comment on or make changes to this bug.