Bug 1257271 - Fix logging version in neutron logs coming from pbr
Fix logging version in neutron logs coming from pbr
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
low Severity unspecified
: z5
: 6.0 (Juno)
Assigned To: Jakub Libosvar
Ofer Blaut
: Triaged, ZStream
Depends On: 1257270
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 11:29 EDT by Jakub Libosvar
Modified: 2016-04-26 14:32 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-neutron-2014.2.3-15.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1257270
Environment:
Last Closed: 2015-10-29 07:39:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Ihar Hrachyshka 2015-08-26 12:00:33 EDT
Do we need it for rhos5 too?
Comment 5 Jakub Libosvar 2015-08-27 07:38:35 EDT
(In reply to Ihar Hrachyshka from comment #3)
> Do we need it for rhos5 too?

Possibly, we can clone the original bug for RHOS 5 too. Can we still slip it into A5?
Comment 6 Ihar Hrachyshka 2015-09-22 08:27:39 EDT
I believe the bug is fixed? I built a package with the patch to use pbr version. If it's indeed enough for the bug, please move to MODIFIED.
Comment 7 Jakub Libosvar 2015-09-29 09:00:14 EDT
(In reply to Ihar Hrachyshka from comment #6)
> I believe the bug is fixed? I built a package with the patch to use pbr
> version. If it's indeed enough for the bug, please move to MODIFIED.

I don't consider this fixed. As per code in current state we will get message "neutron-server version 12.el7ost" which is not the intended message.

We need to either rely on pbr like we do for OSP7 or accommodate neutron/version.py to current approach that uses 'sed' on version.py during package build time.
Comment 9 Ofer Blaut 2015-10-18 04:31:04 EDT
tested

2015-10-18 04:10:12.077 10310 INFO neutron.common.config [-] /usr/bin/neutron-server version 2014.2.3-23.el7ost
Comment 11 errata-xmlrpc 2015-10-29 07:39:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1950.html

Note You need to log in before you can comment on or make changes to this bug.