Bug 125731 - Badness in local_bh_enable at kernel/softirq.c
Badness in local_bh_enable at kernel/softirq.c
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-10 13:59 EDT by Marek Greško
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-05 08:29:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Greško 2004-06-10 13:59:49 EDT
Description of problem:

There appears the following on every DSL shutdown.

Jun 10 19:04:33 server pppoe[1378]: read (syncReadFromPPP): Session
7622: Input/
output error
Jun 10 19:04:33 server pppoe[1378]: Sent PADT
Jun 10 19:04:33 server kernel: Badness in local_bh_enable at
kernel/softirq.c:13
6
Jun 10 19:04:33 server kernel: Call Trace:
Jun 10 19:04:33 server kernel:  [<0211afe4>] local_bh_enable+0x39/0x56
Jun 10 19:04:33 server kernel:  [<22b248fd>] ppp_sync_push+0xaf/0x115
[ppp_synct
ty]
Jun 10 19:04:33 server kernel:  [<22b2443f>] ppp_sync_wakeup+0x1c/0x34
[ppp_sync
tty]
Jun 10 19:04:33 server kernel:  [<021bb50c>] do_tty_hangup+0xeb/0x2d2
Jun 10 19:04:33 server kernel:  [<021bc41e>] release_dev+0x1bc/0x4c0
Jun 10 19:04:33 server kernel:  [<02134fd4>] zap_pmd_range+0x42/0x50
Jun 10 19:04:33 server kernel:  [<0213501e>] unmap_page_range+0x3c/0x57
Jun 10 19:04:33 server kernel:  [<021350fd>] unmap_vmas+0xc4/0x176
Jun 10 19:04:33 server kernel:  [<021bc9fc>] tty_release+0x14/0x2d
Jun 10 19:04:33 server adsl-stop: Killing adsl-connect
Jun 10 19:04:33 server kernel:  [<02141fa7>] __fput+0x3f/0xd1
Jun 10 19:04:33 server kernel:  [<02140d99>] filp_close+0x59/0x5f
Jun 10 19:04:33 server network: Shutting down interface ppp0:  succeeded
Jun 10 19:04:33 server kernel:  [<021193ef>] put_files_struct+0x56/0xa9
Jun 10 19:04:33 server kernel:  [<02119de0>] do_exit+0x1b3/0x2e3
Jun 10 19:04:33 server kernel:  [<02119faa>] sys_exit_group+0x0/0xd


Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358

How reproducible:
Always.

Steps to Reproduce:
1. Start DSL.
2. Stop DSL.
3. Watch logs.
  
Actual results:
There appears Badness.

Expected results:
No badness in log.

Additional info:
Comment 1 Andre Robatino 2004-06-14 14:44:51 EDT
  I have the same problem using DSL with a clean FC2 install on two
different machines (Microtel SYSMAR561 and Emachines 333cs).  It
persists with the 427 and 435 kernels.
Comment 2 Need Real Name 2004-07-12 17:45:17 EDT
I get the same thing - but to screen (on shutdown).
Which log are you looking at?
Comment 3 Andre Robatino 2004-07-13 01:26:08 EDT
  When the xDSL network connection goes down automatically on
shutdown, it only shows on the screen.  However, if you bring the
network connection down manually with Network Device Control without
shutting down, the errors are written to /var/log/messages.
Comment 4 Marek Greško 2004-07-13 03:41:23 EDT
I found it in /var/log/messages after shutdown not manually bringing
down. Here is corresponding line from syslog.conf:

*.info;mail.none;authpriv.none;cron.none      /var/log/messages
Comment 5 Andre Robatino 2004-07-13 11:38:06 EDT
  Strange.  I have the same line in syslog.conf, but my errors are
never written to /var/log/messages unless I bring down the connection
manually.
Comment 6 Andre Robatino 2004-08-03 19:42:52 EDT
  Using kernel-2.6.7-1.494.2.2, the error appears to be gone.  (BTW, I
commented in bug #126190 that it appeared to be a dupe of this bug but
there was no response.)

Note You need to log in before you can comment on or make changes to this bug.