Bug 1257362 - rhc server configure doesn't have a --always-auth option
rhc server configure doesn't have a --always-auth option
Status: CLOSED DUPLICATE of bug 1216206
Product: OpenShift Container Platform
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Fabiano Franz
Yanping Zhang
:
: 1257354 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 17:52 EDT by Eric Jones
Modified: 2015-09-21 14:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-21 14:36:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1216206 None None None Never

  None (edit)
Description Eric Jones 2015-08-26 17:52:16 EDT
Description of problem:
Cannot manually or with the help of a rhc command set always_auth equal to true when more than one server is involved (i.e. when the config uses .openshift/server.yml instead of .openshift/express.conf)

Version-Release number of selected component (if applicable):
OpenShift Enterprise v2.2

How reproducible:
100%

Steps to Reproduce:
1. On a system running OpenShift v2.2 with one server already set on the default dev account, ran "rhc server add openshift.redhat.com".
2. Ran "ls ~/.opnshift" to prove that it created the server.yml file
3. Ran "cat ~/.openshift/server.yml" in order to see that, by default, it doesn't have any always_auth setting
4. Ran "rhc server use online"
5. Ran "rhc region" to prove that it doesn't authenticate
6. Vim into the file to add "always_auth: true"
7. Ran "rhc region" again and still no authentication
8. Ran "cat ~/.openshift/server.yml"  again and saw that the changes were gone
9. Ran "rhc server configure --help" and saw that there is no option to add always_auth or anything similar

Expected results:
# rhc server configure online --always-auth true
success(?) (not sure what the success would look like)

Additional info:
Version 2.2.5 changed the default for the rhc setup command to set always_auth=false and occasionally it needs to be always_auth=true For multiple servers connected to one dev account the configuration file for the server switches from .openshift/express.conf to .openshift/server.yml and in the server.yml always_auth does not work. Both setting it manually and setting it using rhc server configure NickName --always-auth therefore there is no way to set the server to always authenticate when there are more than one server attached to a dev account.
Comment 2 Eric Jones 2015-08-27 09:23:11 EDT
*** Bug 1257354 has been marked as a duplicate of this bug. ***
Comment 3 Timothy Williams 2015-09-21 14:36:34 EDT
This will be resolved by https://github.com/openshift/rhc/commit/b571857746c8d6587dba4711565272a980691313

Fix is being tracked in another bug already: https://bugzilla.redhat.com/show_bug.cgi?id=1216206

*** This bug has been marked as a duplicate of bug 1216206 ***

Note You need to log in before you can comment on or make changes to this bug.