Bug 1257395 - Ovirt hosted engine agent fails to start after deploy to NFSv3 on 3.6 Beta
Ovirt hosted engine agent fails to start after deploy to NFSv3 on 3.6 Beta
Status: CLOSED DUPLICATE of bug 1254745
Product: oVirt
Classification: Community
Component: ovirt-hosted-engine-ha (Show other bugs)
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Doron Fediuck
meital avital
Depends On:
  Show dependency treegraph
Reported: 2015-08-26 22:16 EDT by Darryl Bond
Modified: 2015-08-27 08:21 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-08-27 08:21:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Darryl Bond 2015-08-26 22:16:55 EDT
Description of problem: ovirt_hosted_engine ha agent will not start after successful deploy on Centos 7 with current updates. Ovirt repository set to 3.6 via the Ovirt 3.6 beta release notes.

Version-Release number of selected component (if applicable): 

How reproducible: Fails every attempt.

Steps to Reproduce:
1. Install ovirt_hosted_engine --deploy
2. Successfully create the VM and complete the deploy
3. Check to see if VM is running

Actual results:
The VM is not running and the agent fails with the following errors:
MainThread::INFO::2015-08-27 11:29:36,915::hosted_engine::235::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(_get_hostname) Found certificate common name: ovirt36-h2.gps.local
MainThread::INFO::2015-08-27 11:29:36,916::hosted_engine::577::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(_initialize_vdsm) Initializing VDSM
MainThread::INFO::2015-08-27 11:29:36,973::hosted_engine::620::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(_initialize_storage_images) Connecting the storage
MainThread::INFO::2015-08-27 11:29:36,973::storage_server::110::ovirt_hosted_engine_ha.lib.storage_server.StorageServer::(connect_storage_server) Connecting storage server
MainThread::ERROR::2015-08-27 11:29:36,973::agent::201::ovirt_hosted_engine_ha.agent.agent.Agent::(_run_agent) Error: ''StorageServer' object has no attribute 'storageType'' - trying to restart agent
MainThread::WARNING::2015-08-27 11:29:41,979::agent::204::ovirt_hosted_engine_ha.agent.agent.Agent::(_run_agent) Restarting agent, attempt '9'
MainThread::ERROR::2015-08-27 11:29:41,979::agent::206::ovirt_hosted_engine_ha.agent.agent.Agent::(_run_agent) Too many errors occurred, giving up. Please review the log and consider filing a bug.
MainThread::INFO::2015-08-27 11:29:41,979::agent::143::ovirt_hosted_engine_ha.agent.agent.Agent::(run) Agent shutting down

Expected results:
Successful start of the agent

Additional info:
Comment 1 Darryl Bond 2015-08-27 00:38:47 EDT
And this is the fix:
diff /usr/lib/python2.7/site-packages/ovirt_hosted_engine_ha/lib/storage_server.py.db /usr/lib/python2.7/site-packages/ovirt_hosted_engine_ha/lib/storage_server.py
<         if self.storageType == constants.DOMAIN_TYPE_GLUSTERFS:
>         if self._domain_type == constants.DOMAIN_TYPE_GLUSTERFS:
Comment 2 Simone Tiraboschi 2015-08-27 08:21:05 EDT

*** This bug has been marked as a duplicate of bug 1254745 ***

Note You need to log in before you can comment on or make changes to this bug.