Bug 1257465 - Loading hunspell dictionaries fails in ibus-typing-booster
Loading hunspell dictionaries fails in ibus-typing-booster
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike FABIAN
Fedora Extras Quality Assurance
: Reopened
: 1258707 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 02:51 EDT by Mike FABIAN
Modified: 2016-01-08 21:21 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.2.12-1.fc23 ibus-typing-booster-1.3.0-3.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-08 21:21:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike FABIAN 2015-08-27 02:51:09 EDT
[mfabian@Fedora-Workstation-netinst-x86_6 ~]$ python3
Python 3.4.3 (default, Jun 29 2015, 12:16:01) 
[GCC 5.1.1 20150618 (Red Hat 5.1.1-4)] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import codecs
>>> b=codecs.open('/usr/share/myspell/de_DE.dic').read().decode('ISO-8859-1')
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python3.4/codecs.py", line 319, in decode
    (result, consumed) = self._buffer_decode(data, self.errors, final)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xc4 in position 630: invalid continuation byte
>>> 

On Fedora 22, this works.

This results in ibus-typing-booster not being able to load the dictionaries.
Comment 1 Mike FABIAN 2015-08-27 02:53:59 EDT
[mfabian@Fedora-Workstation-netinst-x86_6 ~]$ python3
Python 3.4.3 (default, Jun 29 2015, 12:16:01) 
[GCC 5.1.1 20150618 (Red Hat 5.1.1-4)] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import codecs
>>> b=codecs.open('/usr/share/myspell/mr_IN.dic').read().decode('UTF-8')
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
AttributeError: 'str' object has no attribute 'decode'
>>>
Comment 2 Fedora Update System 2015-08-27 04:33:26 EDT
ibus-typing-booster-1.2.12-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14392
Comment 3 Fedora Update System 2015-08-27 04:34:47 EDT
ibus-typing-booster-1.2.12-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14393
Comment 4 Fedora Update System 2015-08-27 04:36:09 EDT
ibus-typing-booster-1.2.12-1.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14394
Comment 5 Fedora Update System 2015-08-28 14:53:17 EDT
ibus-typing-booster-1.2.12-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update ibus-typing-booster'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14394
Comment 6 Fedora Update System 2015-08-28 14:57:51 EDT
ibus-typing-booster-1.2.12-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update ibus-typing-booster'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14393
Comment 7 Fedora Update System 2015-08-31 14:53:03 EDT
ibus-typing-booster-1.2.12-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update ibus-typing-booster'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14392
Comment 8 Mike FABIAN 2015-09-01 02:37:28 EDT
*** Bug 1258707 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2015-09-06 13:05:29 EDT
ibus-typing-booster-1.2.12-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2015-09-23 10:33:52 EDT
ibus-typing-booster-1.2.13-1.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16510
Comment 11 Fedora Update System 2015-09-23 10:40:24 EDT
ibus-typing-booster-1.2.13-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16511
Comment 12 Fedora Update System 2015-09-24 05:53:22 EDT
ibus-typing-booster-1.2.13-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ibus-typing-booster'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16510
Comment 13 Fedora Update System 2015-09-25 17:21:25 EDT
ibus-typing-booster-1.2.13-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ibus-typing-booster'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16511
Comment 14 Fedora Update System 2015-10-11 16:04:08 EDT
ibus-typing-booster-1.2.14-1.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-39164b1d67
Comment 15 Fedora Update System 2015-10-11 16:05:41 EDT
ibus-typing-booster-1.2.14-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c36b106343
Comment 16 Fedora Update System 2015-10-13 14:21:25 EDT
ibus-typing-booster-1.2.14-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ibus-typing-booster'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-39164b1d67
Comment 17 Fedora Update System 2015-10-13 14:21:47 EDT
ibus-typing-booster-1.2.14-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ibus-typing-booster'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c36b106343
Comment 18 Fedora Update System 2015-11-02 22:21:29 EST
ibus-typing-booster-1.2.15-1.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-2c65f7392a
Comment 19 Fedora Update System 2015-11-02 22:22:32 EST
ibus-typing-booster-1.2.15-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ccb91a63a8
Comment 20 Fedora Update System 2015-11-03 13:21:43 EST
ibus-typing-booster-1.2.15-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ibus-typing-booster'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-2c65f7392a
Comment 21 Fedora Update System 2015-11-03 13:57:29 EST
ibus-typing-booster-1.2.15-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ibus-typing-booster'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ccb91a63a8
Comment 22 Fedora Update System 2015-12-17 07:26:20 EST
ibus-typing-booster-1.3.0-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-10ffd394ce
Comment 23 Fedora Update System 2015-12-18 06:27:16 EST
ibus-typing-booster-1.3.0-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ibus-typing-booster'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-10ffd394ce
Comment 24 Fedora Update System 2016-01-08 21:21:08 EST
ibus-typing-booster-1.3.0-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.