Bug 1257586 - No error that resource cannot be found
No error that resource cannot be found
Status: VERIFIED
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: Walden Raines
David Davis
http://projects.theforeman.org/issues...
: Reopened, Triaged
: 1279464 (view as bug list)
Depends On:
Blocks: 1122832
  Show dependency treegraph
 
Reported: 2015-08-27 08:06 EDT by Peter Vreman
Modified: 2017-09-14 15:23 EDT (History)
7 users (show)

See Also:
Fixed In Version: rubygem-bastion-3.2.0.8-1,rubygem-katello-3.0.0.74-1,rubygem-bastion-3.2.0.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 04:55:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
contentviews glitch (36.09 KB, image/png)
2016-06-28 12:21 EDT, Roman Plevka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13917 None None None 2016-04-22 11:06 EDT
Foreman Issue Tracker 15352 None None None 2016-06-08 11:41 EDT
Foreman Issue Tracker 15544 None None None 2016-06-29 11:04 EDT
Foreman Issue Tracker 15545 None None None 2016-06-29 11:04 EDT

  None (edit)
Description Peter Vreman 2015-08-27 08:06:04 EDT
Description of problem:
Open a page with ID that does not exists.

The details Pane will keep the "Loading" spinner for at least the following pages:
/products/99999/info
/activation_keys/99999/info

The content view details Pane contains the Tabs and allows even editing a Name:
/content_views/99999/info

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Open WebUI URL with manual replacing the ID with 99999
2.
3.

Actual results:
No error giving that the resource could not be found

Expected results:
Error that the resource does not exists


Additional info:
Comment 2 Walden Raines 2016-02-26 09:38:42 EST
Created redmine issue http://projects.theforeman.org/issues/13917 from this bug
Comment 3 Walden Raines 2016-02-29 15:21:12 EST
PR: https://github.com/Katello/katello/pull/5825
Comment 4 Bryan Kearney 2016-03-07 18:05:46 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13917 has been closed
-------------
Walden Raines
Applied in changeset commit:katello|8d2202608ecde59f23210303451ab3aa4caa57bb.
Comment 5 Peter Vreman 2016-03-08 11:35:31 EST
Does the fix also fix https://bugzilla.redhat.com/show_bug.cgi?id=1279464?
If so then that one can be closed as duplicate.
Comment 6 Walden Raines 2016-03-08 14:11:49 EST
*** Bug 1279464 has been marked as a duplicate of this bug. ***
Comment 7 Walden Raines 2016-03-08 14:12:06 EST
(In reply to Peter Vreman from comment #5)
> Does the fix also fix https://bugzilla.redhat.com/show_bug.cgi?id=1279464?
> If so then that one can be closed as duplicate.

Yes, thanks for pointing that out Peter.
Comment 9 David Davis 2016-04-04 09:16:05 EDT
Verified against 6.2 snap 6. Checked products, repos, and activation keys.
Comment 10 Peter Vreman 2016-05-19 09:00:14 EDT
This is not fully fixed.

Going to /content_views/99999 or /products/99999 still gets into an infinite loop
Comment 11 Justin Sherrill 2016-05-19 09:26:18 EDT
Moving back to assigned based on comment #10
Comment 12 Bryan Kearney 2016-06-08 12:09:28 EDT
Upstream bug component is Uncategorized
Comment 13 Walden Raines 2016-06-08 13:48:59 EDT
PR: https://github.com/Katello/bastion/pull/114
Comment 14 Walden Raines 2016-06-13 10:27:08 EDT
Revision dee91a07
Added by Walden Raines 5 days ago

Fixes #15352: redirect to a 404 page if state does not exist.

We were infinitely redirecting on sub-states that didn't exist. This
commit redirects to a 404 page if a child state is not found.

http://projects.theforeman.org/issues/15352

Revision ba8bea1f
Added by Walden Raines 3 days ago

Merge pull request #114 from waldenraines/15352

Fixes #15352: redirect to a 404 page if state does not exist.
Comment 15 Roman Plevka 2016-06-28 12:21 EDT
Created attachment 1173500 [details]
contentviews glitch

FAILED QA
sat6.2.0 snap17

The error function is in place now and user ends with the error popup saying that resource cannot be found, however, the function takes some time to fetch the data and display the error, so the dialog appears before the error. One can still see the original dialog (especially on the content view page). and if he's quick enough or uses JS debugger to pause the script execution, he's able to click buttons on the form.

e.g. navigate to '/content_views/99999/delete'

- i was able to trigger deletion of the CV ending up with a popup with no text (see attachment)

This should be a synchronous action that won't load the dialog before the resource is fetched from the server.
By following the path of synchronous actions, we should mitigate strange scenarios like this one
Comment 16 Bryan Kearney 2016-06-29 12:08:32 EDT
Upstream bug component is WebUI
Comment 18 Brad Buckingham 2016-07-07 15:29:26 EDT
*** Bug 1353176 has been marked as a duplicate of this bug. ***
Comment 22 errata-xmlrpc 2016-07-27 04:55:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500
Comment 25 Roman Plevka 2017-03-02 05:19:11 EST
VERIFIED

this seems to be fixed now.
6.2.8-4

the katello + foreman endpoints including
/content_views/99999/info or /products/99999

work correctly now.

Note You need to log in before you can comment on or make changes to this bug.