This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1279464 - URL parameters not checked for validation
URL parameters not checked for validation
Status: CLOSED DUPLICATE of bug 1257586
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views (Show other bugs)
6.1.3
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Walden Raines
: Triaged
Depends On:
Blocks: 1122832
  Show dependency treegraph
 
Reported: 2015-11-09 09:14 EST by Peter Vreman
Modified: 2016-03-08 14:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-08 14:11:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
all content view versions listing with invalid ID (365.00 KB, image/png)
2015-11-09 09:14 EST, Peter Vreman
no flags Details

  None (edit)
Description Peter Vreman 2015-11-09 09:14:45 EST
Created attachment 1091759 [details]
all content view versions listing with invalid ID

Description of problem:
The URL parameters are not checked for validation if the ID really exists. Instead it sometimes continues to run on the all resources instead of a single resource item

Having an invalid ID can happen when you still have the UI open on that ID, but in an other session or through the API the Item is deleted.

Simple reproduction is to use a value of 9999

Example of content view versions with ID 9999 is attached in screenshot
/content_views/9999/versions



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Use invalid ID (e.g. 9999) in the URLs
2.
3.

Actual results:
Unpredictable results, e.g. listing of all items

Expected results:
Failure that the identifier cannot be found


Additional info:
Comment 2 Walden Raines 2016-03-08 14:11:49 EST
This is a duplicate of bug #1257586.

*** This bug has been marked as a duplicate of bug 1257586 ***

Note You need to log in before you can comment on or make changes to this bug.