Bug 1257709 - Copy NFS-Ganesha export files as part of volume snapshot creation
Copy NFS-Ganesha export files as part of volume snapshot creation
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
mainline
x86_64 All
high Severity urgent
: ---
: ---
Assigned To: Jiffin
: Triaged
Depends On:
Blocks: 1216951 1246007 1256227 1257710 1261444
  Show dependency treegraph
 
Reported: 2015-08-27 14:10 EDT by Jiffin
Modified: 2016-06-16 09:33 EDT (History)
13 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1246007
: 1257710 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:33:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2015-08-27 14:19:19 EDT
REVIEW: http://review.gluster.org/12034 (snapshot : copying nfs-ganesha export file) posted (#1) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 2 Vijay Bellur 2015-09-04 04:59:36 EDT
REVIEW: http://review.gluster.org/12034 (snapshot : copying nfs-ganesha export file) posted (#2) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 3 Vijay Bellur 2015-09-04 09:11:35 EDT
REVIEW: http://review.gluster.org/12034 (snapshot : copying nfs-ganesha export file) posted (#3) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 4 Vijay Bellur 2015-09-11 04:49:40 EDT
REVIEW: http://review.gluster.org/12034 (snapshot : copying nfs-ganesha export file) posted (#4) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 5 Vijay Bellur 2015-09-15 08:10:01 EDT
REVIEW: http://review.gluster.org/12034 (snapshot : copying nfs-ganesha export file) posted (#5) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 6 Vijay Bellur 2015-10-12 02:38:18 EDT
REVIEW: http://review.gluster.org/12034 (snapshot : copying nfs-ganesha export file) posted (#6) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 7 Vijay Bellur 2015-10-14 09:01:35 EDT
REVIEW: http://review.gluster.org/12034 (snapshot : copying nfs-ganesha export file) posted (#7) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 8 Vijay Bellur 2015-10-16 01:13:00 EDT
REVIEW: http://review.gluster.org/12034 (snapshot : copying nfs-ganesha export file) posted (#8) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 9 Vijay Bellur 2015-10-27 08:06:44 EDT
REVIEW: http://review.gluster.org/12034 (snapshot : copying nfs-ganesha export file) posted (#9) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 10 Vijay Bellur 2015-10-30 16:39:55 EDT
COMMIT: http://review.gluster.org/12034 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 5583bac79851d24f0a552478b361049fe63c32b7
Author: Jiffin Tony Thottan <jthottan@redhat.com>
Date:   Thu Aug 27 23:26:40 2015 +0530

    snapshot : copying nfs-ganesha export file
    
    While taking snapshot, the export file used by the volume should
    copy to snap directory. So that when restore of snapshot happens,
    the volume can retain all its configuration for exporting via
    nfs-ganesha. The export file is stored at "/etc/ganesha/export" in
    the following format "export.<volname>.conf"
    
    The fix handles given cases in the following manner :
    
    case a: The nfs-ganesha(global) is ON during snapshot and restore.
            i.) Volume was exported during snapshot. When we restore snapshot,
                then volume should be exported back with old configuration file.
            ii.) Volume was unexported during snapshot. When we restore snapshot,
                 then volume should unexported again.
    
    case b: The nfs-ganesha is ON during snapshot and OFF during restore
            Volume was exported during snapshot. When we restore snapshot, the
            conf will be copied to corresponding location and if nfs-ganesha enabled
            again, then volume will be exported.
    
    For the clones, export conf file will created in /etc/ganesha/export and then
    export it via ganesha.
    
    Change-Id: Ideecda15bd4db58e991cf6c8de7bb93f3db6cd20
    BUG: 1257709
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/12034
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 11 Niels de Vos 2016-06-16 09:33:45 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.