Bug 1257734 - [RHOS] When the admin user is a member but not an admin of a flavour, it raises an error during provider refresh.
[RHOS] When the admin user is a member but not an admin of a flavour, it rais...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity low
: GA
: 5.4.3
Assigned To: Greg Blomquist
Aziza Karol
: ZStream
: 1267341 (view as bug list)
Depends On: 1245511
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 15:29 EDT by Chris Pelland
Modified: 2015-10-22 10:33 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.4.3.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1245511
Environment:
Last Closed: 2015-10-22 10:33:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2015-09-28 15:08:29 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=da6ae33b472e49d006ac89d83bbb6da97b1c1a8d

commit da6ae33b472e49d006ac89d83bbb6da97b1c1a8d
Merge: 34e1cc4 0086b8c
Author:     Gregg Tanzillo <gtanzill@redhat.com>
AuthorDate: Mon Sep 28 15:04:36 2015 -0400
Commit:     Gregg Tanzillo <gtanzill@redhat.com>
CommitDate: Mon Sep 28 15:04:36 2015 -0400

    Merge branch 'bz1257734-handle-missing-services-better' into '5.4.z'
    
    Handle missing services better
    
    Administrators can configure OpenStack tenants and users in such a way that
    restricts access to certain services on certain tenants.  The
    `OpenstackHandle#detect_service` method handled this by returning `nil` when it
    could not connect to the appropriate service.
    
    However, several callers were not handling the `nil` response properly.
    
    Now, at least callers to `OpenstackHandle#service_for_each_accessible_tenant`
    will only have their block called when the requested service is actually
    available for the tenant.  Otherwise, a warning will be logged, and that
    iteration of the `service_for_each_accessible_tenant` will be skipped.
    
    Upstream PR: https://github.com/ManageIQ/manageiq/pull/4088
    
    Clean merge with:  git am --directory=lib -p3 0001-OpenStack-Handle-missing-services-better.patch
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1245511
    https://bugzilla.redhat.com/show_bug.cgi?id=1257734
    
    See merge request !268

 lib/openstack/openstack_handle/handle.rb | 20 +++++++++++++-------
 1 file changed, 13 insertions(+), 7 deletions(-)
Comment 3 CFME Bot 2015-09-28 15:08:39 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=0086b8c10c0276642adb48e596ad61452d3e764b

commit 0086b8c10c0276642adb48e596ad61452d3e764b
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Thu Aug 27 15:55:53 2015 -0400
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Mon Sep 28 09:56:43 2015 -0400

    Handle missing services better
    
    Administrators can configure OpenStack tenants and users in such a way that
    restricts access to certain services on certain tenants.  The
    `OpenstackHandle#detect_service` method handled this by returning `nil` when it
    could not connect to the appropriate service.
    
    However, several callers were not handling the `nil` response properly.
    
    Now, at least callers to `OpenstackHandle#service_for_each_accessible_tenant`
    will only have their block called when the requested service is actually
    available for the tenant.  Otherwise, a warning will be logged, and that
    iteration of the `service_for_each_accessible_tenant` will be skipped.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1245511
    https://bugzilla.redhat.com/show_bug.cgi?id=1257734

 lib/openstack/openstack_handle/handle.rb | 20 +++++++++++++-------
 1 file changed, 13 insertions(+), 7 deletions(-)
Comment 4 Marius Cornea 2015-09-30 10:38:30 EDT
*** Bug 1267341 has been marked as a duplicate of this bug. ***
Comment 6 Aziza Karol 2015-10-07 06:10:53 EDT
Good to go.

Verified in 5.4.3.0.20151001120745_d11cf59
Comment 8 errata-xmlrpc 2015-10-22 10:33:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1916.html

Note You need to log in before you can comment on or make changes to this bug.