Bug 1267341 - Openstack cloud refresh fails when adding the admin user as a member in other tenant
Openstack cloud refresh fails when adding the admin user as a member in other...
Status: CLOSED DUPLICATE of bug 1257734
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
unspecified Severity high
: GA
: 5.5.0
Assigned To: Greg Blomquist
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 13:18 EDT by Marius Cornea
Modified: 2015-11-11 15:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 10:38:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error log (4.04 KB, text/plain)
2015-09-29 13:18 EDT, Marius Cornea
no flags Details

  None (edit)
Description Marius Cornea 2015-09-29 13:18:05 EDT
Created attachment 1078438 [details]
error log

Description of problem:
The Openstack cloud provider refresh fails after adding the admin user as a member in other tenant.

Version-Release number of selected component (if applicable):
5.4.2.0.20150820153254_83e434d

How reproducible:
100%

Steps to Reproduce:
1. Register Openstack Cloud provider by using the admin user
2. In Openstack create a new tenant(project) 
3. Add the admin user as a member of that  project

Actual results:
Cloud refresh fails with: undefined method `directories' for nil:NilClass

Expected results:
Cloud refresh finishes. 

Additional info:
Attaching log.
Comment 2 Marius Cornea 2015-09-29 13:21:17 EDT
Refresh worked after assigning the admin user the admin role in the tenant.
Comment 3 Marius Cornea 2015-09-30 10:38:30 EDT

*** This bug has been marked as a duplicate of bug 1257734 ***

Note You need to log in before you can comment on or make changes to this bug.