Bug 1257746 - Display error message when using a subscription account that lacks correct entitlements
Display error message when using a subscription account that lacks correct en...
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 1.0
Assigned To: Jesus M. Rodriguez
Antonin Pagac
: Triaged
Depends On:
Blocks: rhci-sprint-16
  Show dependency treegraph
 
Reported: 2015-08-27 16:18 EDT by John Matthews
Modified: 2016-09-13 12:21 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:21:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
account with no subscriptions (52.19 KB, image/png)
2016-06-27 11:07 EDT, Antonin Pagac
no flags Details

  None (edit)
Description John Matthews 2015-08-27 16:18:26 EDT
Description of problem:

As of tech-preview if we use a subscription account which lacks correct entitlements, such as a new access.redhat.com account with _no_ subscriptions, the deployment will not advance past the subscriptions page. 

This behavior is correct of not advancing, but we want it to display an error message so the user knows why it is not advancing.

As of tech-preview I see no feedback/message, the webui appears to be hung.
Comment 1 jmagen@redhat.com 2015-12-16 09:02:26 EST
Can you send me credentials of a new access.redhat.com account with no subscriptions so I can use the response. Do you mean that there are no subscription management applications as well and none can be created??
Comment 2 jmagen@redhat.com 2016-04-27 07:26:35 EDT
This has been already fixed. Please verify.
Comment 3 Antonin Pagac 2016-06-27 11:07:27 EDT
I've tried this with a SMA that has no subscriptions, see screenshot, and it allowed me to continue by clicking on the 'Next' button. During the validation phase there were no errors displayed and no errors are on Installation Review page. After clicking the Deploy button, the deployment fails with.

"Product 'Red Hat Enterprise Linux Server' does not exist. Confirm that a manifest containing it has been imported."

So the deployment advanced past the Subscription section and allowed me to proceed and start the actual deployment before failing with above error.

I think it would be nicer to display warning/error message in the subscription section when it's obvious the deployment will fail, thus allowing the user to correct the mistake and try again, as opposed to failing the whole deployment.

Joseph, can we convert this to a RFE?
Comment 4 Antonin Pagac 2016-06-27 11:07 EDT
Created attachment 1172912 [details]
account with no subscriptions
Comment 5 jmagen@redhat.com 2016-07-05 10:07:26 EDT
I'm asking for Jesus Rodriguez's help on this BZ.
Comment 6 Jesus M. Rodriguez 2016-07-05 10:35:00 EDT
Re-assigning to myself as it it directly related to the subscription work I'm doing.
Comment 7 Jesus M. Rodriguez 2016-07-14 14:07:45 EDT
Fixed by the subscription validation feature
Comment 8 John Matthews 2016-07-18 17:07:30 EDT
QCI-1.2-RHEL-7-20160718.t.0
Comment 13 Antonin Pagac 2016-08-11 05:58:37 EDT
Verified in 20160809.t.1
Comment 15 errata-xmlrpc 2016-09-13 12:21:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.