Bug 1285434 - Validation, Second deployment allows to skip the Subscriptions section (verify entitlements meet need)
Validation, Second deployment allows to skip the Subscriptions section (verif...
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHCI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity high
: ga
: 1.0
Assigned To: Jesus M. Rodriguez
Antonin Pagac
Dan Macpherson
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 10:12 EST by Antonin Pagac
Modified: 2016-09-13 12:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:23:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Antonin Pagac 2016-06-28 05:01:42 EDT
Second deployment still allows to skip the Subscription section, I can start the deployment with insufficient subscriptions. It then hangs when installing RHEV and waiting for the Data Center to be green.

When I look to Satellite's Content Hosts, I can see the two hypervisors have:

"Subscription Status Fully entitled"

whereas the engine has:

"Subscription Status Fully entitled 
Details

    Red Hat Cloud Infrastructure, Premium (2-sockets): Guest has not been reported on any host and is using a temporary unmapped guest subscription."

Also Katello Agent reports as not installed on the engine machine.

I believe this is the correct behavior, however there was no verification if the entitlements meet need. There should be some checking in the Subscription section, and an error or at least a warning should be displayed when user tries to proceed without correct entitlements and it is obvious the deployment will fail.
There is relevant bug 1257746 that talks about displaying an error.
Comment 2 jmagen@redhat.com 2016-07-06 03:43:41 EDT
John, Jesus, is there a UI issue that I need to look at for this? If so, can you guide me.
Comment 3 Jesus M. Rodriguez 2016-07-08 00:05:14 EDT
The new subscriptions validation will cover this scenario.

* if a new connected deployment, we count the subscriptions required by the deployment. And look at the customer portal for the counts specified in the SMA you associated to the deployment. If it isn't enough we warn you.

* if a new disconnected deployment, we count the subscriptions required by the deployment. And look at the manifest you uploaded for the counts required. If it isn't enough we warn you.

* for subsequent deployments, where a manifest has already been uploaded to the satellite, we count the subscriptions required by the deployment. And look at the satellite for what is available, if it isn't enough we warn you.
Comment 4 Jesus M. Rodriguez 2016-07-08 00:05:24 EDT
https://github.com/fusor/fusor/pull/1016
Comment 5 John Matthews 2016-07-18 17:12:18 EDT
QCI-1.2-RHEL-7-20160718.t.0
Comment 10 Antonin Pagac 2016-08-11 06:00:58 EDT
Verified in 20160809.t.1
Comment 12 errata-xmlrpc 2016-09-13 12:23:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.