Bug 1257792 - bug-1238706-daemons-stop-on-peer-cleanup.t fails occasionally
bug-1238706-daemons-stop-on-peer-cleanup.t fails occasionally
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
All All
high Severity high
: ---
: ---
Assigned To: Atin Mukherjee
: Reopened, Triaged
Depends On:
Blocks: 1258306
  Show dependency treegraph
 
Reported: 2015-08-28 01:13 EDT by Raghavendra Talur
Modified: 2017-05-30 14:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.11.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1258306 (view as bug list)
Environment:
Last Closed: 2017-05-30 14:32:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Talur 2015-08-28 01:13:40 EDT
Description of problem:

bug-1238706-daemons-stop-on-peer-cleanup.t fails sometimes at 
EXPECT_WITHIN $PROCESS_UP_TIMEOUT "2" get_nfs_count.

There might be an underlying race in Gluster Code or the test makes wrong
assumptions.

This bug is only for the test, if the issue is in Gluster Code, please
file another bug for that.
Comment 1 Anand Avati 2015-08-28 01:18:27 EDT
REVIEW: http://review.gluster.org/12036 (tests: Mark bug-1238706-daemons-stop-on-peer-cleanup.t as bad) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 2 Anand Avati 2015-08-28 01:21:57 EDT
REVIEW: http://review.gluster.org/12036 (tests: Mark bug-1238706-daemons-stop-on-peer-cleanup.t as bad) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 3 Raghavendra Talur 2016-03-08 15:02:07 EST
"tests" component is for tests framework only.
File a bug under test component if you find a bug in 
1. any of the *.rc files under tests/ 
2. run-tests.sh


For everything else, the bug should be filed on
1. component which is being tested by .t file if the .t file requires fix.
2. component which is causing a valid .t file to fail in regression.

I have used my best judgement here to move the bug to right component.
In case of ambiguity, I have placed the blame on the .t file component.

Please consider test bugs under the same backlog list that tracks other bugs in your component.
Comment 4 Mike McCune 2016-03-28 18:22:31 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 5 Niels de Vos 2016-06-16 09:34:27 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 6 Worker Ant 2017-02-02 03:09:09 EST
REVIEW: https://review.gluster.org/16514 (tests : turn off nfs.disable in bug-1238706-daemons-stop-on-peer-cleanup.t) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 7 Worker Ant 2017-02-07 08:03:11 EST
COMMIT: https://review.gluster.org/16514 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 3c86d946086fda97b38f1a28682840adacbbf800
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Feb 2 13:37:31 2017 +0530

    tests : turn off nfs.disable in bug-1238706-daemons-stop-on-peer-cleanup.t
    
    To validate this test and remove it from the list of bad tests, turn off
    nfs.disable option so that nfs daemon can come up.
    
    Change-Id: I8146c2d7f72ac53cac7e395dbb9e819d729eb6a9
    BUG: 1257792
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: https://review.gluster.org/16514
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 8 Shyamsundar 2017-05-30 14:32:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.