Bug 1258306 - bug-1238706-daemons-stop-on-peer-cleanup.t fails occasionally
bug-1238706-daemons-stop-on-peer-cleanup.t fails occasionally
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Atin Mukherjee
:
Depends On: 1257792
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 23:46 EDT by Atin Mukherjee
Modified: 2015-09-09 05:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1257792
Environment:
Last Closed: 2015-09-09 05:41:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Atin Mukherjee 2015-08-30 23:46:12 EDT
+++ This bug was initially created as a clone of Bug #1257792 +++

Description of problem:

bug-1238706-daemons-stop-on-peer-cleanup.t fails sometimes at 
EXPECT_WITHIN $PROCESS_UP_TIMEOUT "2" get_nfs_count.

There might be an underlying race in Gluster Code or the test makes wrong
assumptions.

This bug is only for the test, if the issue is in Gluster Code, please
file another bug for that.

--- Additional comment from Anand Avati on 2015-08-28 01:18:27 EDT ---

REVIEW: http://review.gluster.org/12036 (tests: Mark bug-1238706-daemons-stop-on-peer-cleanup.t as bad) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)

--- Additional comment from Anand Avati on 2015-08-28 01:21:57 EDT ---

REVIEW: http://review.gluster.org/12036 (tests: Mark bug-1238706-daemons-stop-on-peer-cleanup.t as bad) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 1 Anand Avati 2015-08-31 00:06:37 EDT
REVIEW: http://review.gluster.org/12050 (tests: Mark bug-1238706-daemons-stop-on-peer-cleanup.t as bad) posted (#1) for review on release-3.7 by Atin Mukherjee (amukherj@redhat.com)
Comment 2 Anand Avati 2015-08-31 02:33:07 EDT
COMMIT: http://review.gluster.org/12050 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit 889f9511a46c5e02007f70f567d2e0eaa2c9f41a
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Fri Aug 28 10:46:11 2015 +0530

    tests: Mark bug-1238706-daemons-stop-on-peer-cleanup.t as bad
    
    backport of http://review.gluster.org/#/c/12036/
    
    This test fails frequently. Use bug number 1257792 when you
    move this test out of bad_tests.
    
    Change-Id: Ib65f22096dc9af131c4d2f38b59a857c549a674a
    BUG: 1258306
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/12036
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Reviewed-on: http://review.gluster.org/12050
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Kaushal 2015-09-09 05:41:03 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.