Bug 1258118 - transmission-qt SIGSEGV
transmission-qt SIGSEGV
Status: CLOSED DUPLICATE of bug 1255902
Product: Fedora
Classification: Fedora
Component: transmission (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-29 06:33 EDT by Sergei LITVINENKO
Modified: 2015-08-29 08:13 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-29 08:13:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergei LITVINENKO 2015-08-29 06:33:24 EDT
Description of problem:
transmission-qt crash

Version-Release number of selected component (if applicable):
transmission-qt-2.84-7.fc22.x86_64

How reproducible:
100%

Steps to Reproduce:
1. /usr/bin/transmission-qt
2.
3.

Actual results:
crash

Expected results:
run as usually

Additional info:

[sergeil@homedesk ~]$ gdb /bin/transmission-qt
...
(gdb) run
Starting program: /usr/bin/transmission-qt 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffd12d9700 (LWP 2686)]
[New Thread 0x7fffde802700 (LWP 2685)]

Program received signal SIGSEGV, Segmentation fault.
0x0000000000000000 in ?? ()                                                    
(gdb)bt                                                                         
#0  0x0000000000000000 in  ()
#1  0x00007ffff61eb970 in QMenuPrivate::syncPlatformMenu() (this=0x555555bc8340) at widgets/qmenu.cpp:198
#2  0x00007ffff61ebb17 in QMenu::setPlatformMenu(QPlatformMenu*) (this=this@entry=0x555555bcbfb0, platformMenu=<optimized out>) at widgets/qmenu.cpp:3325
#3  0x00007ffff63e0b65 in QSystemTrayIconPrivate::addPlatformMenu(QMenu*) const (this=0x555555b215a0, menu=0x555555bcbfb0) at util/qsystemtrayicon.cpp:763   
#4  0x00007ffff63e0c37 in QSystemTrayIconPrivate::updateMenu_sys_qpa() (this=0x555555b215a0) at util/qsystemtrayicon.cpp:712
#5  0x00007ffff63fcf2f in QSystemTrayIconPrivate::updateMenu_sys() (this=<optimized out>) at util/qsystemtrayicon_x11.cpp:327
#6  0x00007ffff63e00e0 in QSystemTrayIcon::setContextMenu(QMenu*) (this=this@entry=0x5555559e41b0, menu=<optimized out>) at util/qsystemtrayicon.cpp:171
#7  0x00005555555bac97 in TrMainWindow::TrMainWindow(Session&, Prefs&, TorrentModel&, bool) (this=0x5555559e4150, session=..., prefs=..., model= 
    ..., minimized=<optimized out>) at mainwin.cc:235
#8  0x000055555558b745 in MyApp::MyApp(int&, char**) (this=0x7fffffffd520, argc=<optimized out>, argv=<optimized out>) at app.cc:170
#9  0x0000555555586f85 in main(int, char**) (argc=1, argv=0x7fffffffd728) at app.cc:534
Comment 1 Helio Chissini de Castro 2015-08-29 08:13:20 EDT

*** This bug has been marked as a duplicate of bug 1255902 ***

Note You need to log in before you can comment on or make changes to this bug.