Bug 1255902 - crash qt5 apps with QSystemTrayIcon context menu
crash qt5 apps with QSystemTrayIcon context menu
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kf5-frameworkintegration (Show other bugs)
22
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Helio Chissini de Castro
Fedora Extras Quality Assurance
: Reopened
: 1255757 1255912 1257679 1257976 1258118 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-21 16:12 EDT by Fl@sh
Modified: 2015-09-09 19:20 EDT (History)
18 users (show)

See Also:
Fixed In Version: 5.13.0-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-09 19:20:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug-demo source (87.28 KB, application/x-gzip)
2015-08-21 16:12 EDT, Fl@sh
no flags Details
fedora 22 QSystemTrayIcon crash (185.06 KB, image/png)
2015-08-24 09:27 EDT, Bober
no flags Details

  None (edit)
Description Fl@sh 2015-08-21 16:12:32 EDT
Created attachment 1065697 [details]
bug-demo source

Description of problem:
after update to current version apps with custom context menu in systemtray is crashed.


Version-Release number of selected component (if applicable):
# rpm -q qt5-qtbase
qt5-qtbase-5.5.0-15.fc22.x86_64

How reproducible:
build testcase with -DBUILD_QT_VERSION=5

Steps to Reproduce:
1.
2.
3.

Actual results:
crashed

Expected results:
build without problems

Additional info:
Comment 1 Fl@sh 2015-08-21 16:19:10 EDT
Additional:
   in openbox-session building occured without problems.
Comment 2 Bober 2015-08-24 09:22:32 EDT
same problem
Comment 3 Bober 2015-08-24 09:27:13 EDT
Created attachment 1066394 [details]
fedora 22 QSystemTrayIcon crash
Comment 4 Helio Chissini de Castro 2015-08-25 08:43:27 EDT
*** Bug 1255757 has been marked as a duplicate of this bug. ***
Comment 5 Helio Chissini de Castro 2015-08-25 08:51:17 EDT
Hello all 

The issue was identified on the plastformtheme plugin from frameworks integration, not Qt5

If you don't use plasma-desktop as your main desktop, you can safely remove kf5-frameworkintegration from system until this issue was solved.

The related plugin is /usr/{lib,lib64}/qt5/plugins/platformthemes/KDEPlatformTheme.so 

Regards
Comment 6 Helio Chissini de Castro 2015-08-25 14:37:56 EDT
Another update

We identified an optimization bug on kf5-frameworkintegration and turning this off solves the issue, will be included in next arriving frameworks update.
Besides, this is not the proper solution, as we workarounded the bug.

At least, immediate issues will be solved.
Comment 7 Helio Chissini de Castro 2015-08-27 15:06:59 EDT
Fixed on current updates-testing package kf5-frameworkintegration-5.13.0-1.fc22

Regards, Helio
Comment 8 Helio Chissini de Castro 2015-08-27 15:10:47 EDT
*** Bug 1255912 has been marked as a duplicate of this bug. ***
Comment 9 Helio Chissini de Castro 2015-08-29 08:08:49 EDT
*** Bug 1257976 has been marked as a duplicate of this bug. ***
Comment 10 Helio Chissini de Castro 2015-08-29 08:13:20 EDT
*** Bug 1258118 has been marked as a duplicate of this bug. ***
Comment 11 Markus S. 2015-08-31 22:20:19 EDT
(In reply to Helio Chissini de Castro from comment #7)
> Fixed on current updates-testing package
> kf5-frameworkintegration-5.13.0-1.fc22

There is no such package in updates-testing.
Comment 12 Rex Dieter 2015-09-01 08:49:29 EDT
The fix is in kf5-frameworkintegration-5.13.0-2.fc22
Comment 13 Rex Dieter 2015-09-03 09:11:38 EDT
*** Bug 1257679 has been marked as a duplicate of this bug. ***
Comment 14 Andy F 2015-09-03 12:21:14 EDT
Still can't see this package in updates-testing
Comment 15 Rex Dieter 2015-09-03 12:38:01 EDT
We're waiting for updates push to happen, sorry.  You can watch,
https://bodhi.fedoraproject.org/updates/FEDORA-2015-14272
Comment 16 Markus S. 2015-09-03 19:37:02 EDT
I installed the RPM by hand. With it several GUI elements are overly large (maybe a margin problem): The title bar is too high and the digital clock widget's date is next to the time instead of below it (this is Plasma 5.3.95 from drvatil's COPR).
Comment 17 Andy F 2015-09-04 09:29:46 EDT
(In reply to Rex Dieter from comment #15)
> We're waiting for updates push to happen, sorry.  You can watch,
> https://bodhi.fedoraproject.org/updates/FEDORA-2015-14272

Still processing. Is there any way to download this manually?
Comment 18 Rex Dieter 2015-09-04 09:32:34 EDT
1. (as root):
dnf --enablerepo=updates-testing update kf5-*

2. then, you can manually download and install the newer kf5-frameworkintegration via
http://koji.fedoraproject.org/koji/buildinfo?buildID=680287
Comment 19 Andy F 2015-09-04 09:42:39 EDT
(In reply to Rex Dieter from comment #18)
> 1. (as root):
> dnf --enablerepo=updates-testing update kf5-*
> 
> 2. then, you can manually download and install the newer
> kf5-frameworkintegration via
> http://koji.fedoraproject.org/koji/buildinfo?buildID=680287

Thankyou Rex.

I did this, and it fixed the ownCloud crash for me on F22.
Comment 20 rh 2015-09-07 05:10:56 EDT
The same issue affects the Seafile Qt client on F22 (crashes on startup when KDE is running).

I can confirm that updating the packages fixes the issue and makes the client show up in the system tray, but when clicking on the icon nothing happens and I couldn't find a way to access the context menu at all. Could be intended behavior though, I don't normally use KDE.
Comment 21 Casey Link 2015-09-08 06:52:00 EDT
Updating to kf5-frameworkintegration*-5.13.0-2 fixed the crash in ownCloud and Zeal (http://zealdocs.org/) for me. Thanks guys!
Comment 22 Fedora Update System 2015-09-09 19:20:05 EDT
extra-cmake-modules-5.13.0-1.fc22, kf5-5.13.0-1.fc22, kf5-attica-5.13.0-1.fc22, kf5-bluez-qt-5.13.0-1.fc22, kf5-frameworkintegration-5.13.0-2.fc22, kf5-kactivities-5.13.0-1.fc22, kf5-kapidox-5.13.0-1.fc22, kf5-karchive-5.13.0-1.fc22, kf5-kauth-5.13.0-1.fc22, kf5-kbookmarks-5.13.0-1.fc22, kf5-kcmutils-5.13.0-1.fc22, kf5-kcodecs-5.13.0-1.fc22, kf5-kcompletion-5.13.0-1.fc22, kf5-kconfig-5.13.0-1.fc22, kf5-kconfigwidgets-5.13.0-1.fc22, kf5-kcoreaddons-5.13.0-1.fc22, kf5-kcrash-5.13.0-1.fc22, kf5-kdbusaddons-5.13.0-1.fc22, kf5-kdeclarative-5.13.0-1.fc22, kf5-kded-5.13.0-1.fc22, kf5-kdelibs4support-5.13.0-1.fc22, kf5-kdesignerplugin-5.13.0-1.fc22, kf5-kdesu-5.13.0-1.fc22, kf5-kdewebkit-5.13.0-1.fc22, kf5-kdnssd-5.13.0-1.fc22, kf5-kdoctools-5.13.0-1.fc22, kf5-kemoticons-5.13.0-1.fc22, kf5-kfilemetadata-5.13.0-1.fc22, kf5-kglobalaccel-5.13.0-1.fc22, kf5-kguiaddons-5.13.0-1.fc22, kf5-khtml-5.13.0-1.fc22, kf5-ki18n-5.13.0-1.fc22, kf5-kiconthemes-5.13.0-1.fc22, kf5-kidletime-5.13.0-1.fc22, kf5-kimageformats-5.13.0-1.fc22, kf5-kinit-5.13.0-1.fc22, kf5-kio-5.13.0-2.fc22, kf5-kitemmodels-5.13.0-1.fc22, kf5-kitemviews-5.13.0-1.fc22, kf5-kjobwidgets-5.13.0-1.fc22, kf5-kjs-5.13.0-1.fc22, kf5-kjsembed-5.13.0-1.fc22, kf5-kmediaplayer-5.13.0-1.fc22, kf5-knewstuff-5.13.0-1.fc22, kf5-knotifications-5.13.0-1.fc22, kf5-knotifyconfig-5.13.0-1.fc22, kf5-kpackage-5.13.0-1.fc22, kf5-kparts-5.13.0-1.fc22, kf5-kpeople-5.13.0-1.fc22, kf5-kplotting-5.13.0-1.fc22, kf5-kpty-5.13.0-1.fc22, kf5-kross-5.13.0-1.fc22, kf5-krunner-5.13.0-1.fc22, kf5-kservice-5.13.0-1.fc22, kf5-ktexteditor-5.13.0-1.fc22, kf5-ktextwidgets-5.13.0-1.fc22, kf5-kunitconversion-5.13.0-1.fc22, kf5-kwallet-5.13.0-1.fc22, kf5-kwidgetsaddons-5.13.0-1.fc22, kf5-kwindowsystem-5.13.0-1.fc22, kf5-kxmlgui-5.13.0-1.fc22, kf5-kxmlrpcclient-5.13.0-1.fc22, kf5-modemmanager-qt-5.13.0-1.fc22, kf5-networkmanager-qt-5.13.0-1.fc22, kf5-plasma-5.13.0-1.fc22, kf5-solid-5.13.0-1.fc22, kf5-sonnet-5.13.0-1.fc22, kf5-threadweaver-5.13.0-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.