Bug 1258122 - UnboundLocalError: local variable 'e' referenced before assignment
UnboundLocalError: local variable 'e' referenced before assignment
Status: CLOSED DUPLICATE of bug 1249304
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:dc69f3b38b87ec0211ad32e6ca4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-29 07:23 EDT by A.J. Werkman
Modified: 2015-08-31 07:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 07:45:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (222.53 KB, text/plain)
2015-08-29 07:23 EDT, A.J. Werkman
no flags Details
File: anaconda.log (12.07 KB, text/plain)
2015-08-29 07:23 EDT, A.J. Werkman
no flags Details
File: dnf.log (751 bytes, text/plain)
2015-08-29 07:23 EDT, A.J. Werkman
no flags Details
File: environ (494 bytes, text/plain)
2015-08-29 07:23 EDT, A.J. Werkman
no flags Details
File: lsblk_output (2.67 KB, text/plain)
2015-08-29 07:23 EDT, A.J. Werkman
no flags Details
File: nmcli_dev_list (1.13 KB, text/plain)
2015-08-29 07:23 EDT, A.J. Werkman
no flags Details
File: os_info (451 bytes, text/plain)
2015-08-29 07:23 EDT, A.J. Werkman
no flags Details
File: program.log (21.24 KB, text/plain)
2015-08-29 07:23 EDT, A.J. Werkman
no flags Details
File: storage.log (63.10 KB, text/plain)
2015-08-29 07:23 EDT, A.J. Werkman
no flags Details
File: syslog (92.44 KB, text/plain)
2015-08-29 07:23 EDT, A.J. Werkman
no flags Details
File: ifcfg.log (1.77 KB, text/plain)
2015-08-29 07:23 EDT, A.J. Werkman
no flags Details
File: packaging.log (221 bytes, text/plain)
2015-08-29 07:23 EDT, A.J. Werkman
no flags Details

  None (edit)
Description A.J. Werkman 2015-08-29 07:23:30 EDT
Version-Release number of selected component:
anaconda-23.17-1

The following was filed automatically by anaconda:
anaconda 23.17-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/tasks/fsminsize.py", line 57, in _getResizeInfo
    error_msg = "failed to gather info from resize program: %s" % e
  File "/usr/lib/python3.4/site-packages/blivet/tasks/fsminsize.py", line 168, in doTask
    resize_info = self._getResizeInfo()
  File "/usr/lib/python3.4/site-packages/blivet/formats/fs.py", line 288, in updateSizeInfo
    result = self._minsize.doTask()
  File "/usr/lib/python3.4/site-packages/blivet/formats/fs.py", line 134, in __init__
    self.updateSizeInfo()
  File "/usr/lib/python3.4/site-packages/blivet/formats/__init__.py", line 85, in getFormat
    fmt = fmt_class(*args, **kwargs)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 1431, in handleUdevDeviceFormat
    device.format = formats.getFormat(format_designator, **kwargs)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 761, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 1660, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 1597, in populate
    self._populate()
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 554, in populate
    self._populator.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 279, in reset
    self.devicetree.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python3.4/site-packages/blivet/osinstall.py", line 1123, in storageInitialize
    storage.reset()
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 171, in raise_if_error
    raise exc_info[0](exc_info[1]).with_traceback(exc_info[2])
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 116, in wait
    self.raise_if_error(name)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/timezone.py", line 76, in time_initialize
    threadMgr.wait(THREAD_STORAGE)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
UnboundLocalError: local variable 'e' referenced before assignment

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz selinux=0 ip=172.18.92.70::172.18.92.65:255.255.255.192:cfl.lc.digifarma.nl::off noipv6 nameserver=172.18.92.65 inst.stage2=hd:UUID=4738807b-c0c0-44eb-9fe9-5b0f3287ad3c inst.repo=http://thlin.digifarma.nl/fedora/development/23/x86_64/os
dnf.rpm.log:    Aug 29 19:15:00 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        23
Comment 1 A.J. Werkman 2015-08-29 07:23:33 EDT
Created attachment 1068254 [details]
File: anaconda-tb
Comment 2 A.J. Werkman 2015-08-29 07:23:35 EDT
Created attachment 1068255 [details]
File: anaconda.log
Comment 3 A.J. Werkman 2015-08-29 07:23:36 EDT
Created attachment 1068256 [details]
File: dnf.log
Comment 4 A.J. Werkman 2015-08-29 07:23:37 EDT
Created attachment 1068257 [details]
File: environ
Comment 5 A.J. Werkman 2015-08-29 07:23:38 EDT
Created attachment 1068258 [details]
File: lsblk_output
Comment 6 A.J. Werkman 2015-08-29 07:23:39 EDT
Created attachment 1068259 [details]
File: nmcli_dev_list
Comment 7 A.J. Werkman 2015-08-29 07:23:40 EDT
Created attachment 1068260 [details]
File: os_info
Comment 8 A.J. Werkman 2015-08-29 07:23:42 EDT
Created attachment 1068261 [details]
File: program.log
Comment 9 A.J. Werkman 2015-08-29 07:23:44 EDT
Created attachment 1068262 [details]
File: storage.log
Comment 10 A.J. Werkman 2015-08-29 07:23:46 EDT
Created attachment 1068263 [details]
File: syslog
Comment 11 A.J. Werkman 2015-08-29 07:23:47 EDT
Created attachment 1068264 [details]
File: ifcfg.log
Comment 12 A.J. Werkman 2015-08-29 07:23:48 EDT
Created attachment 1068265 [details]
File: packaging.log
Comment 13 Martin Kolman 2015-08-31 07:45:30 EDT

*** This bug has been marked as a duplicate of bug 1249304 ***

Note You need to log in before you can comment on or make changes to this bug.