Bug 1258236 - mouse scroll wheel no longer works after upgrade f22->f23
mouse scroll wheel no longer works after upgrade f22->f23
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
RejectedBlocker AcceptedFreezeException
:
: 1254169 1261504 (view as bug list)
Depends On:
Blocks: F23BetaFreezeException
  Show dependency treegraph
 
Reported: 2015-08-30 09:22 EDT by Cole Robinson
Modified: 2015-09-16 17:59 EDT (History)
9 users (show)

See Also:
Fixed In Version: 3.17.8-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-16 14:36:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sudo libinput-list-devices (2.57 KB, text/plain)
2015-08-30 09:23 EDT, Cole Robinson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 753431 None None None Never

  None (edit)
Description Cole Robinson 2015-08-30 09:22:59 EDT
My mouse scroll wheel no longer works after upgrading from f22 to f23. I verified the scroll wheel works on a mac laptop so it doesn't seem to be a hardware issue. Middle click with the wheel _does_ work however.

I ran 'sudo showkey' and no button presses showed up for any scrollwheel movement.

Running 'sudo libinput-debug-events' does show results when I move the scroll wheel though, example

event5 	POINTER_AXIS	+29.24s	vert 15.00 horiz 0.00
event5 	POINTER_AXIS	+29.41s	vert 15.00 horiz 0.00
event5 	POINTER_AXIS	+29.73s	vert 15.00 horiz 0.00
event5 	POINTER_AXIS	+30.11s	vert 15.00 horiz 0.00
event5 	POINTER_AXIS	+30.48s	vert 15.00 horiz 0.00
event5 	POINTER_AXIS	+31.03s	vert -15.00 horiz 0.00
event5 	POINTER_AXIS	+31.08s	vert -15.00 horiz 0.00
event5 	POINTER_AXIS	+31.18s	vert -15.00 horiz 0.00
event5 	POINTER_AXIS	+31.27s	vert -15.00 horiz 0.00

Let me know if I can provide more info

$ rpm -q libinput
libinput-0.99.1-1.fc23.x86_64
Comment 1 Cole Robinson 2015-08-30 09:23:37 EDT
Created attachment 1068427 [details]
sudo libinput-list-devices
Comment 2 Cole Robinson 2015-08-30 13:39:24 EDT
Actually turns out the scrollwheel works in firefox, but not nautilus or gnome-terminal or epiphany. So maybe gtk3?
Comment 3 Fedora Blocker Bugs Application 2015-09-13 09:56:01 EDT
Proposed as a Blocker for 23-beta by Fedora user bentiss using the blocker tracking app because:

 I consider having regular mouse wheel working (under Xorg) as a minimum to release a new milestone.
At least 2 other bugs are duplicate: 1261504 & 1254169.
Comment 4 Benjamin Tissoires 2015-09-13 09:57:18 EDT
As mentioned in bug 1254169, the wheel is working properly on Gtk3 under Wayland.
Comment 5 Benjamin Tissoires 2015-09-13 09:57:43 EDT
*** Bug 1261504 has been marked as a duplicate of this bug. ***
Comment 6 Cole Robinson 2015-09-13 13:22:14 EDT
The upstream bug is https://bugzilla.gnome.org/show_bug.cgi?id=753431 , and there appear to be patches committed
Comment 7 Benjamin Tissoires 2015-09-13 17:44:38 EDT
(In reply to Cole Robinson from comment #6)
> The upstream bug is https://bugzilla.gnome.org/show_bug.cgi?id=753431 , and
> there appear to be patches committed

Yep, I confirm applying the patch mentioned in this bug solves the issue.

Matthias, Carlos, can one of you apply and push this for F23?
Comment 8 Kalev Lember 2015-09-13 18:31:50 EDT
I backported the patch to gtk3-3.17.8-2.fc23
Comment 9 Fedora Update System 2015-09-13 19:11:52 EDT
gtk3-3.17.8-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15770
Comment 10 Adam Williamson 2015-09-14 12:14:58 EDT
Discussed at 2015-09-14 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-09-14/f23-blocker-review.2015-09-14-16.00.log.txt . Rejected as a blocker, as the criteria do not contain a "whatever Cole considers" clause and this doesn't violate any of the ones that do exist. ;) Accepted as a freeze exception issue: while not being a blocker this is obviously annoying and cannot be fixed with an update at least for live images and the installer environment.
Comment 11 Fedora Update System 2015-09-14 13:50:53 EDT
gtk3-3.17.8-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update gtk3'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15770
Comment 12 Fedora Update System 2015-09-16 14:36:06 EDT
gtk3-3.17.8-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Kalev Lember 2015-09-16 17:59:21 EDT
*** Bug 1254169 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.